summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 9358b5a52c..9052a34e96 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -391,6 +391,7 @@ extracting icontainer icon files.")
(package
(name "libtiff")
(version "4.0.9")
+ (replacement libtiff/fixed)
(source
(origin
(method url-fetch)
@@ -420,6 +421,17 @@ collection of tools for doing simple manipulations of TIFF images.")
"See COPYRIGHT in the distribution."))
(home-page "http://www.simplesystems.org/libtiff/")))
+(define libtiff/fixed
+ (package
+ (inherit libtiff)
+ (source
+ (origin
+ (inherit (package-source libtiff))
+ (patches
+ (append (origin-patches (package-source libtiff))
+ (search-patches "libtiff-CVE-2017-9935.patch"
+ "libtiff-CVE-2017-18013.patch")))))))
+
(define-public leptonica
(package
(name "leptonica")