aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm93
1 files changed, 91 insertions, 2 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5a3542b4aa..6b7f41c906 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2014, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2014, 2017 John Darrington <jmd@gnu.org>
@@ -17,6 +17,8 @@
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -809,7 +811,14 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
("python2-sphinx" ,python2-sphinx)))
(arguments
`(#:test-target "check"
- #:parallel-build? #f ; parallel builds trigger an ICE
+ #:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/ukoethe/vigra/issues/432
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ (substitute* "test/fourier/CMakeLists.txt"
+ (("VIGRA_ADD_TEST.*") ""))
+ #t)))
#:configure-flags
(list "-Wno-dev" ; suppress developer mode with lots of warnings
(string-append "-DVIGRANUMPY_INSTALL_DIR="
@@ -835,6 +844,39 @@ multi-dimensional image processing.")
(license license:expat)
(home-page "https://ukoethe.github.io/vigra/")))
+(define-public vigra-c
+ (let* ((commit "a2ff675f42079e2623318d8ff8b4288dbe7a7f06")
+ (revision "0")
+ (version (git-version "0.0.0" revision commit)))
+ (package
+ (name "vigra-c")
+ (version version)
+ (home-page "https://github.com/BSeppke/vigra_c")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "1f1phmfbbz3dsq9330rd6bjmdg29hxskxi9l17cyx1f4mdqpgdgl"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No test target.
+ (native-inputs
+ `(("doxygen" ,doxygen)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("fftwf" ,fftwf)
+ ("vigra" ,vigra)))
+ (synopsis "C interface to the VIGRA computer vision library")
+ (description
+ "This package provides a C interface to the VIGRA C++ computer vision
+library. It is designed primarily to ease the implementation of higher-level
+language bindings to VIGRA.")
+ (license license:expat))))
+
(define-public libwebp
(package
(name "libwebp")
@@ -1358,3 +1400,50 @@ Features:
images stored in the JPEG format with R. It can read and write both files and
in-memory raw vectors.")
(license license:gpl2+)))
+
+(define-public gifsicle
+ (package
+ (name "gifsicle")
+ (version "1.91")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.lcdf.org/gifsicle/gifsicle-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00586z1yz86qcblgmf16yly39n4lkjrscl52hvfxqk14m81fckha"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "test/testie"
+ (("/usr/bin/perl")
+ (which "perl"))
+ (("/bin/sh")
+ (which "sh"))
+ (("/bin/rm")
+ (which "rm")))
+ #t)))))
+ (native-inputs `(("perl" ,perl))) ; Only for tests.
+ (inputs `(("libx11" ,libx11)))
+ (home-page "http://www.lcdf.org/gifsicle/")
+ (synopsis "Edit GIF images and animations")
+ (description "Gifsicle is a command-line GIF image manipulation tool that:
+
+@itemize
+@item Provides a batch mode for changing GIFs in place.
+@item Prints detailed information about GIFs, including comments.
+@item Control over interlacing, comments, looping, transparency, etc.
+@item Creates well-behaved GIFs: removes redundant colors, only uses local color
+tables, etc.
+@item Shrinks colormaps and change images to use the Web-safe palette.
+@item Optimizes GIF animations, or unoptimizes them for easier editing.
+@end itemize
+
+Two other programs are included with Gifsicle: @command{gifview} is a
+lightweight animated-GIF viewer, and @command{gifdiff} compares two GIFs for
+identical visual appearance.")
+ (license license:gpl2+)))