summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index dfb68488ee..9d705939e3 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -65,10 +65,10 @@
"02vhdv16nf4kjna4inpbfy4k3p40bhl7xpc4kh4xvily14146l2b"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-delete 'configure %standard-phases)
- #:tests? #f ;FIXME: Requires 'perl-test-command'.
- #:make-flags
- (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ '(#:phases (modify-phases %standard-phases (delete 'configure))
+ #:tests? #f ;FIXME: Requires 'perl-test-command'.
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
(inputs `(("imlib2" ,imlib2)
("curl" ,curl)
("libpng" ,libpng)
@@ -178,9 +178,8 @@ It is the default image viewer on LXDE desktop environment.")
'(#:tests? #f ; no check target
#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")
- #:phases (alist-delete
- 'configure ; no configure phase
- %standard-phases)))
+ ;; no configure phase
+ #:phases (modify-phases %standard-phases (delete 'configure))))
(inputs
`(("libx11" ,libx11)
("imlib2" ,imlib2)