summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index f5d67c8917..cdaf8e86e2 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -89,7 +89,7 @@
(inputs
`(;; Our ICU is too recent: “error: ‘UChar’ does not name a type“.
;; ("icu4c" ,icu4c)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
("libxml2" ,libxml2)
@@ -137,7 +137,7 @@ licences similar to the Modified BSD licence."))))
("gts" ,gts)
("hdf5" ,hdf5)
("itpp" ,itpp)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
("libxml" ,libxml2)
@@ -198,7 +198,7 @@ of external libraries that provide additional functionality.")
("expat" ,expat)
("freetype" ,freetype)
("hdf5" ,hdf5)
- ("jpeg" ,libjpeg)
+ ("jpeg" ,libjpeg-turbo)
("jsoncpp" ,jsoncpp)
("libogg" ,libogg)
("libtheora" ,libtheora)
@@ -393,7 +393,7 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
(patches (search-patches "opencv-rgbd-aarch64-test-fix.patch"))
(sha256
(base32 "1f334glf39nk42mpqq6j732h3ql2mpz89jd4mcl678s8n73nfjh2"))))))
- (inputs `(("libjpeg" ,libjpeg)
+ (inputs `(("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("jasper" ,jasper)
;; ffmpeg 4.0 causes core dumps in tests.
@@ -454,7 +454,7 @@ vision algorithms. It can be used to do things like:
("gobject-introspection" ,gobject-introspection)))
(inputs
`(("glib" ,glib)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("librsvg" ,librsvg)
("libtiff" ,libtiff)
@@ -516,7 +516,7 @@ due to its architecture which automatically parallelises the image workflows.")
("gtk+-2" ,gtk+-2)
("libxml2" ,libxml2)
("libexif" ,libexif)
- ("libjpeg" ,libjpeg) ; required by vips.pc
+ ("libjpeg" ,libjpeg-turbo) ;required by vips.pc
("librsvg" ,librsvg)
("fftw" ,fftw)
("libgsf" ,libgsf)
@@ -573,7 +573,7 @@ recalculates.")
(inputs
`(("libgeotiff" ,libgeotiff)
("libtiff" ,libtiff)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("zlib" ,zlib)))
(home-page "https://github.com/vxl/vxl/")
@@ -650,7 +650,7 @@ libraries designed for computer vision research and implementation.")
("fftw" ,fftw)
("fftwf" ,fftwf)
("hdf5" ,hdf5)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)
("mesa" ,mesa-opencl)