summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm41
1 files changed, 24 insertions, 17 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 3d1709fcc3..b2a53b5f41 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -2,6 +2,8 @@
;;; Copyright © 2014, 2015, 2016, 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,8 +35,9 @@
#:use-module (gnu packages base)
#:use-module (gnu packages texinfo)
#:use-module (guix git-download)
- #:export (hurd-triplet?
- hurd-target?))
+ #:export (hurd-system?
+ hurd-target?
+ hurd-triplet?))
(define (hurd-triplet? triplet)
(and (string-suffix? "-gnu" triplet)
@@ -44,7 +47,12 @@
"Return true if the cross-compilation target or the current system is
GNU/Hurd."
(or (and=> (%current-target-system) hurd-triplet?)
- (string-suffix? (%current-system) "-gnu")))
+ (and (not (%current-target-system))
+ (and=> (%current-system) hurd-triplet?))))
+
+(define (hurd-system?)
+ "Return true if the current system is the Hurd."
+ (and=> (%current-system) hurd-triplet?))
(define (hurd-source-url version)
(string-append "mirror://gnu/hurd/hurd-"
@@ -129,11 +137,11 @@ communication.")
(define-public hurd-headers
;; Resort to a post-0.9 snapshot that provides the 'file_utimens' and
;; 'file_exec_paths' RPCs that glibc 2.28 expects.
- (let ((revision "0")
- (commit "98b33905c89b7e5c309c74ae32302a5745901a6e"))
+ (let ((revision "1")
+ (commit "91a51672ff4cfe1f1a0712b4c542ded3081c825b"))
(package
(name "hurd-headers")
- (version "0.9")
+ (version (git-version "0.9" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -141,7 +149,7 @@ communication.")
(commit commit)))
(sha256
(base32
- "1mj22sxgscas2675vrbxr477mwbxdj68pqcrh65lbir8qlssrgrf"))
+ "16k9wkahz9wasviijz53n6i13nmiwa9fs64ikf1jqh8rl60hw7cz"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
@@ -167,6 +175,7 @@ communication.")
"--disable-ncursesw"
"--disable-test"
"--without-libbz2"
+ "--without-libcrypt"
"--without-libz"
;; Skip the clnt_create check because it expects
;; a working glibc causing a circular dependency.
@@ -273,14 +282,9 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(define-public hurd
(package
(name "hurd")
- (version "0.9")
- (source (origin
- (method url-fetch)
- (uri (hurd-source-url version))
- (sha256
- (base32
- "1nw9gly0n7pyv3cpfm4mmxy4yccrx4g0lyrvd3vk2vil26jpbggw"))
- (patches (search-patches "hurd-fix-eth-multiplexer-dependency.patch"))))
+ (version (package-version hurd-headers))
+ (source (origin (inherit (package-source hurd-headers))
+ (patches (search-patches "hurd-cross.patch"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -299,8 +303,11 @@ Hurd-minimal package which are needed for both glibc and GCC.")
(build-system gnu-build-system)
(inputs `(("glibc-hurd-headers" ,glibc/hurd-headers)))
(native-inputs
- `(("mig" ,mig)
- ("perl" ,perl)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("mig" ,mig)
+ ("perl" ,perl)
+ ("texinfo" ,texinfo-4)))
(supported-systems %hurd-systems)
(home-page "https://www.gnu.org/software/hurd/hurd.html")
(synopsis "The kernel servers for the GNU operating system")