summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm92
1 files changed, 92 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2977398880..37b9b262fc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages sdl)
@@ -381,6 +383,28 @@ over threads in Haskell, in which @code{Async a} is a concurrent thread that
will eventually deliver a value of type @code{a}.")
(license license:bsd-3)))
+(define-public ghc-atomic-primops
+ (package
+ (name "ghc-atomic-primops")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/atomic-primops"
+ "/atomic-primops-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cyr2x6xqz6s233znrz9rnrfj56m9bmnawwnka0lsqqy1hp8gy37"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-primitive" ,ghc-primitive)))
+ (home-page "https://github.com/rrnewton/haskell-lockfree/wiki")
+ (synopsis "Safe approach to CAS and other atomic ops")
+ (description
+ "GHC 7.4 introduced a new @code{casMutVar} PrimOp which is difficult to
+use safely, because pointer equality is a highly unstable property in Haskell.
+This library provides a safer method based on the concept of @code{Ticket}s.")
+ (license license:bsd-3)))
+
(define-public ghc-atomic-write
(package
(name "ghc-atomic-write")
@@ -6730,6 +6754,43 @@ between 2 and 3 times faster than the Mersenne Twister.")
`(("ghc-hashable" ,ghc-hashable-bootstrap)))
(properties '((hidden? #t)))))
+(define-public ghc-ncurses
+ (package
+ (name "ghc-ncurses")
+ (version "0.2.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ncurses/ncurses-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gsyyaqyh5r9zc0rhwpj5spyd6i4w2vj61h4nihgmmh0yyqvf3z5"))))
+ (build-system haskell-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-includes
+ (lambda _
+ (substitute* '("cbits/hsncurses-shim.h"
+ "lib/UI/NCurses.chs"
+ "lib/UI/NCurses/Enums.chs"
+ "lib/UI/NCurses/Panel.chs")
+ (("<ncursesw/") "<"))
+ #t)))
+ #:cabal-revision
+ ("1"
+ "1wfdy716s5p1sqp2gsg43x8wch2dxg0vmbbndlb2h3d8c9jzxnca")))
+ (inputs `(("ncurses" ,ncurses)))
+ (native-inputs `(("ghc-c2hs" ,ghc-c2hs)))
+ (home-page "https://john-millikin.com/software/haskell-ncurses/")
+ (synopsis "Modernised bindings to GNU ncurses")
+ (description "GNU ncurses is a library for creating command-line application
+with pseudo-graphical interfaces. This package is a nice, modern binding to GNU
+ncurses.")
+ (license license:gpl3)))
+
(define-public ghc-network
(package
(name "ghc-network")
@@ -10605,6 +10666,37 @@ processes. It wraps around the @code{process} library, and intends to improve
upon it.")
(license license:expat)))
+(define-public ghc-unagi-chan
+ (package
+ (name "ghc-unagi-chan")
+ (version "0.4.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/unagi-chan"
+ "/unagi-chan-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lnl5n4jnjmm4chp461glcwkrrw63rjz3fvprwxcy3lkpbkrqvgn"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-atomic-primops" ,ghc-atomic-primops)
+ ("ghc-primitive" ,ghc-primitive)))
+ (arguments
+ `(#:tests? #f ; FIXME: Tests expect primitive 0.7
+ #:cabal-revision
+ ("1"
+ "09pqi867wskwgc5lpn197f895mbn1174ydgllvcppcsmrz2b6yr6")))
+ (home-page "http://hackage.haskell.org/package/unagi-chan")
+ (synopsis "Fast concurrent queues with a Chan-like API, and more")
+ (description
+ "This library provides implementations of concurrent FIFO queues (for
+both general boxed and primitive unboxed values) that are fast, perform well
+under contention, and offer a Chan-like interface. The library may be of
+limited usefulness outside of x86 architectures where the fetch-and-add
+instruction is not available.")
+ (license license:bsd-3)))
+
(define-public ghc-unbounded-delays
(package
(name "ghc-unbounded-delays")