summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 217c78a08c..37b9b262fc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages sdl)
@@ -6753,6 +6754,43 @@ between 2 and 3 times faster than the Mersenne Twister.")
`(("ghc-hashable" ,ghc-hashable-bootstrap)))
(properties '((hidden? #t)))))
+(define-public ghc-ncurses
+ (package
+ (name "ghc-ncurses")
+ (version "0.2.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ncurses/ncurses-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gsyyaqyh5r9zc0rhwpj5spyd6i4w2vj61h4nihgmmh0yyqvf3z5"))))
+ (build-system haskell-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-includes
+ (lambda _
+ (substitute* '("cbits/hsncurses-shim.h"
+ "lib/UI/NCurses.chs"
+ "lib/UI/NCurses/Enums.chs"
+ "lib/UI/NCurses/Panel.chs")
+ (("<ncursesw/") "<"))
+ #t)))
+ #:cabal-revision
+ ("1"
+ "1wfdy716s5p1sqp2gsg43x8wch2dxg0vmbbndlb2h3d8c9jzxnca")))
+ (inputs `(("ncurses" ,ncurses)))
+ (native-inputs `(("ghc-c2hs" ,ghc-c2hs)))
+ (home-page "https://john-millikin.com/software/haskell-ncurses/")
+ (synopsis "Modernised bindings to GNU ncurses")
+ (description "GNU ncurses is a library for creating command-line application
+with pseudo-graphical interfaces. This package is a nice, modern binding to GNU
+ncurses.")
+ (license license:gpl3)))
+
(define-public ghc-network
(package
(name "ghc-network")