summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 832288523b..39e94b780b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8306,17 +8306,15 @@ code. It was designed for use in @code{Pandoc}.")
(define-public ghc-pandoc
(package
(name "ghc-pandoc")
- (version "2.7.3")
+ (version "2.9.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/pandoc/pandoc-"
version ".tar.gz"))
- (patches (search-patches "ghc-pandoc-fix-html-tests.patch"
- "ghc-pandoc-fix-latex-test.patch"))
(sha256
(base32
- "0dpjrr40h54cljzhvixyym07z792a9izg6b9dmqpjlgcg4rj0xx8"))))
+ "1f9wbwzv6c3dlsn15iydh921icjqj7kjgrb726kqmj5gmaypc39j"))))
(build-system haskell-build-system)
(inputs
`(("ghc-aeson" ,ghc-aeson)
@@ -8327,7 +8325,9 @@ code. It was designed for use in @code{Pandoc}.")
("ghc-cmark-gfm" ,ghc-cmark-gfm)
("ghc-data-default" ,ghc-data-default)
("ghc-diff" ,ghc-diff)
+ ("ghc-doclayout" ,ghc-doclayout)
("ghc-doctemplates" ,ghc-doctemplates)
+ ("ghc-emojis" ,ghc-emojis)
("ghc-executable-path" ,ghc-executable-path)
("ghc-glob" ,ghc-glob)
("ghc-haddock-library" ,ghc-haddock-library)
@@ -8340,6 +8340,7 @@ code. It was designed for use in @code{Pandoc}.")
("ghc-http-client-tls" ,ghc-http-client-tls)
("ghc-http-types" ,ghc-http-types)
("ghc-ipynb" ,ghc-ipynb)
+ ("ghc-jira-wiki-markup" ,ghc-jira-wiki-markup)
("ghc-juicypixels" ,ghc-juicypixels)
("ghc-network" ,ghc-network)
("ghc-network-uri" ,ghc-network-uri)