summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3acb48a96d..5dc66c1625 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -588,7 +588,7 @@ document syntax.
Guile-Reader’s approach is similar to Common Lisp’s “read table”, but
hopefully more powerful and flexible (for instance, one may instantiate as
many readers as needed).")
- (home-page "http://www.nongnu.org/guile-reader/")
+ (home-page "https://www.nongnu.org/guile-reader/")
(license license:gpl3+)))
(define-public guile2.0-reader
@@ -799,7 +799,7 @@ $(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
#t)))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("guile" ,guile-2.2)))
- (home-page "http://www.nongnu.org/guile-lib/")
+ (home-page "https://www.nongnu.org/guile-lib/")
(synopsis "Collection of useful Guile Scheme modules")
(description
"Guile-Lib is intended as an accumulation place for pure-scheme Guile
@@ -842,7 +842,7 @@ for Guile\".")
(string-append all "/@GUILE_EFFECTIVE_VERSION@")))))))
(build-system gnu-build-system)
(native-inputs `(("guile" ,guile-2.2)))
- (home-page "http://savannah.nongnu.org/projects/guile-json/")
+ (home-page "https://savannah.nongnu.org/projects/guile-json/")
(synopsis "JSON module for Guile")
(description
"Guile-JSON supports parsing and building JSON documents according to the
@@ -1190,8 +1190,8 @@ Guile's foreign function interface.")
(deprecated-package "guile2.2-gdbm-ffi" guile-gdbm-ffi))
(define-public guile-sqlite3
- (let ((commit "1cd1dec96a9999db48c0ff45bab907efc637247f")
- (revision "3"))
+ (let ((commit "10c13a7e02ab1655c8a758e560cafc9d6eff26f4")
+ (revision "4"))
(package
(name "guile-sqlite3")
(version (git-version "0.0" revision commit))
@@ -1207,7 +1207,7 @@ Guile's foreign function interface.")
(commit commit)))
(sha256
(base32
- "0vvdgwcshrgl6dfz5cxf0l9bl44nkgah0ph3vv464d55nd8qh4b6"))
+ "0nhhswpd7nb2f0gfr55fzcc2xm3l2xx4rbljsd1clrm8fj2d7q9d"))
(file-name (string-append name "-" version "-checkout"))
(modules '((guix build utils)))
(snippet
@@ -1350,7 +1350,7 @@ above command-line parameters.")
(build-system gnu-build-system)
(native-inputs
`(("guile" ,guile-2.0)))
- (home-page "http://savannah.nongnu.org/projects/guile-redis/")
+ (home-page "https://savannah.nongnu.org/projects/guile-redis/")
(synopsis "Redis client library for Guile")
(description "Guile-redis provides a Scheme interface to the Redis
key-value cache and store.")
@@ -1520,7 +1520,7 @@ wrappers for inter-language calls. It currently only supports generating Guile
wrappers for C functions. Given a definition of the types and prototypes for
a given C interface, G-Wrap will automatically generate the C code that
provides access to that interface and its types from the Scheme level.")
- (home-page "http://www.nongnu.org/g-wrap/index.html")
+ (home-page "https://www.nongnu.org/g-wrap/index.html")
(license license:lgpl2.1+)))
(define-public guile-dbi