summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm69
1 files changed, 31 insertions, 38 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 91a440d928..ddd34ae7dc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -769,7 +769,7 @@ format is also supported.")
(symlink "README.org" "README")
(zero? (system* "autoreconf" "-fi")))))))
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("texinfo" ,texinfo)
;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
@@ -1259,14 +1259,14 @@ Guile's foreign function interface.")
(define-public haunt
(package
(name "haunt")
- (version "0.2.1")
+ (version "0.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/haunt/haunt-"
version ".tar.gz"))
(sha256
(base32
- "1fpaf1vm6s7j13fs35barjh5yajcc2rc3pi8r7278wpgp4i2vs3w"))))
+ "0nm00krmqq4zmqi2irh35dbf2cn6al58s620hijmhfvhgvdqznlp"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 match) (ice-9 ftw)
@@ -1283,12 +1283,15 @@ Guile's foreign function interface.")
out "/share/guile/site")))
(match (scandir site)
(("." ".." version)
- (let ((modules (string-append site "/" version)))
+ (let ((modules (string-append site "/" version))
+ (compiled-modules (string-append
+ out "/lib/guile/" version
+ "/site-ccache")))
(wrap-program (string-append bin "/haunt")
`("GUILE_LOAD_PATH" ":" prefix
(,modules))
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,modules)))
+ (,compiled-modules)))
#t)))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1856,7 +1859,7 @@ dictionary and suggesting spelling corrections.")
(string-append "--libdir=" (assoc-ref %outputs "out")
"/lib/bash"))))
(native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,(autoconf-wrapper))
+ ("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)
;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
@@ -1957,8 +1960,8 @@ is not available for Guile 2.0.")
(license license:lgpl3+)))
(define-public guile-git
- (let ((revision "4")
- (commit "951a32c56cc4d80f8836e3c7394783e69c1fcbad"))
+ (let ((revision "5")
+ (commit "2bb9fbbf93cf93496718efc85ad9394aefa21029"))
(package
(name "guile-git")
(version (string-append "0.0-" revision "." (string-take commit 7)))
@@ -1968,7 +1971,7 @@ is not available for Guile 2.0.")
(uri (git-reference (url home-page) (commit commit)))
(sha256
(base32
- "0qri9x73ij6g40ijs4hyhj8knxw39ydgghiafq74dp99bc8hh0qc"))
+ "0z3v0v89dyp35zx2h2gsq6v29lba3wbzabc5n2g4hx2fcb6q5qqy"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -2008,40 +2011,30 @@ manipulate repositories of the Git version control system.")
(package-for-guile-2.0 guile-git))
(define-public guile-syntax-highlight
- (let ((commit "a047675e66861b647426372aa2ba7820f749616d")
- (revision "0"))
- (package
- (name "guile-syntax-highlight")
- (version (string-append "0.0." revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://dthompson.us/guile-syntax-highlight.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1zjr6sg3n7xbdsliy45i39dqanxvcms58ayx36wxrz72zpq58vq3"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "sh" "bootstrap")))))))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("guile" ,guile-2.2)))
+ (package
+ (name "guile-syntax-highlight")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://files.dthompson.us/"
+ "guile-syntax-highlight/"
+ "guile-syntax-highlight-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1p771kq15x83483m23bhah1sz6vkalg3drm7x279f4j1cxligkzi"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))
(synopsis "General-purpose syntax highlighter for GNU Guile")
(description "Guile-syntax-highlight is a general-purpose syntax
highlighting library for GNU Guile. It can parse code written in various
programming languages into a simple s-expression that can be converted to
HTML (via SXML) or any other format for rendering.")
- (home-page "http://dthompson.us/software/guile-syntax-highlight")
- (license license:lgpl3+))))
+ (home-page "http://dthompson.us/projects/guile-syntax-highlight.html")
+ (license license:lgpl3+)))
(define-public guile-sjson
(package