summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm183
1 files changed, 167 insertions, 16 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1c1b35c34b..7ce6683681 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Erik Edrosa <erik.edrosa@gmail.com>
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;; Copyright © 2016 Amirouche <amirouche@hypermove.net>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -230,7 +231,7 @@ without requiring the source code to be rewritten.")
(define-public guile-next
(package (inherit guile-2.0)
(name "guile-next")
- (version "2.1.4")
+ (version "2.1.5")
(replacement #f)
(source (origin
(method url-fetch)
@@ -238,7 +239,7 @@ without requiring the source code to be rewritten.")
version ".tar.xz"))
(sha256
(base32
- "1w8kyy8nz6489d092fix6lvgjrk0bww7i0c2k67ym4hq0kjl0r1j"))
+ "0r9y4hw17dlxahik4zsccfb2f3p2a07wqndfm251bgmam9hln6gi"))
(modules '((guix build utils)))
;; Remove the pre-built object files. Instead, build everything
@@ -247,7 +248,10 @@ without requiring the source code to be rewritten.")
(snippet '(for-each delete-file
(find-files "prebuilt" "\\.go$")))))
(synopsis "Snapshot of what will become version 2.2 of GNU Guile")
- (properties '((timeout . 72000))) ; 20 hours
+ (properties '((timeout . 72000) ;20 hours
+ (upstream-name . "guile")
+ (ftp-server . "alpha.gnu.org")
+ (ftp-directory . "/gnu/guile")))
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -428,16 +432,20 @@ many readers as needed).")
"--with-gnu-filesystem-hierarchy")
#:phases
(modify-phases %standard-phases
- (add-after 'install 'post-install
+ (add-before 'build 'fix-libguile-ncurses-file-name
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/share/guile/site/"))
- (files (find-files dir ".scm")))
- (substitute* files
- (("\"libguile-ncurses\"")
- (format #f "\"~a/lib/guile/2.0/libguile-ncurses\""
- out)))
- #t))))))
+ (and (zero? (system* "make" "install"
+ "-C" "src/ncurses"
+ "-j" (number->string
+ (parallel-job-count))))
+ (let* ((out (assoc-ref outputs "out"))
+ (dir "src/ncurses")
+ (files (find-files dir ".scm")))
+ (substitute* files
+ (("\"libguile-ncurses\"")
+ (format #f "\"~a/lib/guile/2.0/libguile-ncurses\""
+ out)))
+ #t)))))))
(home-page "https://www.gnu.org/software/guile-ncurses/")
(synopsis "Guile bindings to ncurses")
(description
@@ -518,6 +526,46 @@ format is also supported.")
(,modules)))
#t))))))))))))
+(define-public guile-ics
+ (package
+ (name "guile-ics")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-ics")
+ (commit "v0.1.1")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1pvg6j48inpbq47hq00yh5hhl2qd2srvrx5yjl7w7ky1jsjadp86"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'autoreconf
+ (lambda _
+ ;; Repository comes with a broken symlink
+ (delete-file "README")
+ (symlink "README.org" "README")
+ (zero? (system* "autoreconf" "-fi")))))))
+ (native-inputs
+ `(("autoconf" ,(autoconf-wrapper))
+ ("automake" ,automake)
+ ("texinfo" ,texinfo)
+ ;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs `(("guile" ,guile-2.0) ("which" ,which)))
+ (propagated-inputs `(("guile-lib" ,guile-lib)))
+ (home-page "https://github.com/artyom-poptsov/guile-ics")
+ (synopsis "Guile parser library for the iCalendar format")
+ (description
+ "Guile-ICS is an iCalendar (RFC5545) format parser library written in
+pure Scheme. The library can be used to read and write iCalendar data.
+
+The library is shipped with documentation in Info format and usage examples.")
+ (license gpl3+)))
+
(define-public guile-lib
(package
(name "guile-lib")
@@ -689,7 +737,7 @@ See http://minikanren.org/ for more on miniKanren generally.")
(define-public guile-irregex
(package
(name "guile-irregex")
- (version "0.9.4")
+ (version "0.9.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -697,7 +745,7 @@ See http://minikanren.org/ for more on miniKanren generally.")
version ".tar.gz"))
(sha256
(base32
- "0cmaqvqvyarcnnsyrl2p6vwyv1r3k1q7qw8p9zrlnz1vpbj7vb90"))))
+ "1ia3m7dp3lcxa048q0gqbiwwsyvn99baw6xkhb4bhhzn4k7bwyqq"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build utils)
@@ -1419,4 +1467,107 @@ type system, elevating types to first-class status.")
dictionary and suggesting spelling corrections.")
(license gpl3+)))
+(define-public guile-bash
+ ;; This project is currently retired. It was initially announced here:
+ ;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.
+ (let ((commit "1eabc563ca5692b3e08d84f1f0e6fd2283284469")
+ (revision "0"))
+ (package
+ (name "guile-bash")
+ (version (string-append "0.1.6-" revision "." (string-take commit 7)))
+ (home-page
+ "https://anonscm.debian.org/cgit/users/kaction-guest/retired/dev.guile-bash.git")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit commit)
+ (url home-page)))
+ (sha256
+ (base32
+ "097vny990wp2qpjij6a5a5gwc6fxzg5wk56inhy18iki5v6pif1p"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (zero? (system* "sh" "bootstrap")))))
+
+ #:configure-flags
+ ;; Add -I to match 'bash.pc' of Bash 4.4.
+ (list (string-append "CPPFLAGS=-I"
+ (assoc-ref %build-inputs "bash:include")
+ "/include/bash/include")
+
+ ;; The '.a' file is useless.
+ "--disable-static"
+
+ ;; Install 'lib/bash' as Bash 4.4 expects.
+ (string-append "--libdir=" (assoc-ref %outputs "out")
+ "/lib/bash"))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("autoconf" ,(autoconf-wrapper))
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
+ ("gettext" ,gettext-minimal)))
+ (inputs `(("guile" ,guile-2.0)
+ ("bash:include" ,bash "include")))
+ (synopsis "Extend Bash using Guile")
+ (description
+ "Guile-Bash provides a shared library and set of Guile modules,
+allowing you to extend Bash in Scheme. Scheme interfaces allow you to access
+the following aspects of Bash:
+
+@itemize
+@item aliases;
+@item setting and getting Bash variables;
+@item creating dynamic variables;
+@item creating Bash functions with a Scheme implementation;
+@item reader macro for output capturing;
+@item reader macro for evaluating raw Bash commands.
+@end itemize
+
+To enable it, run:
+
+@example
+enable -f ~/.guix-profile/lib/bash/libguile-bash.so scm
+@end example
+
+and then run @command{scm example.scm}.")
+ (license gpl3+))))
+
+(define-public guile-8sync
+ (package
+ (name "guile-8sync")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/8sync/8sync-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1fvf8d2s3vvg4nyskbqaiqmlm2x571hv7hizcnmny45zvalydr9h"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("guile" ,guile-next)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ ;; quiet warnings
+ (setenv "GUILE_AUTO_COMPILE" "0")
+ #t)))))
+ (home-page "https://gnu.org/s/8sync/")
+ (synopsis "Asynchronous actor model library for Guile")
+ (description
+ "GNU 8sync (pronounced \"eight-sync\") is an asynchronous programming
+library for GNU Guile based on the actor model.
+
+Note that 8sync is only available for Guile 2.2 (guile-next in Guix).")
+ (license lgpl3+)))
+
;;; guile.scm ends here