summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 289158ea1b..cb88308278 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -230,6 +230,7 @@ without requiring the source code to be rewritten.")
"1269ymxm56j1z1lvq1y42rm961f2n7rinm3k6l00p9k52hrpcddk"))
(modules '((guix build utils)))
(patches (search-patches
+ "guile-finalization-crash.patch"
"guile-2.2-skip-oom-test.patch"))
;; Remove the pre-built object files. Instead, build everything
@@ -250,18 +251,6 @@ without requiring the source code to be rewritten.")
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-public guile-2.2/bug-fix
- ;; This variant contains a bug fix for a relatively rare crash that could
- ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
- (package
- (inherit guile-2.2)
- (version (string-append (package-version guile-2.2) "-1"))
- (source (origin
- (inherit (package-source guile-2.2))
- (patches
- (append (search-patches "guile-finalization-crash.patch")
- (origin-patches (package-source guile-2.2))))))))
-
(define-public guile-2.2/fixed
;; A package of Guile 2.2 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.
@@ -295,7 +284,8 @@ without requiring the source code to be rewritten.")
version ".tar.xz"))
(sha256
(base32
- "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))))
+ "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))
+ (patches (search-patches "guile-2.2-skip-oom-test.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments guile-2.2)
;; XXX: On ARMv7, work around <https://bugs.gnu.org/39208> by disabling
@@ -563,6 +553,8 @@ Guile's foreign function interface.")
(base32
"1nv8j7wk6b5n4p22szyi8lv8fs31rrzxhzz16gyj8r38c1fyp9qp"))
(file-name (string-append name "-" version "-checkout"))
+ (patches
+ (search-patches "guile-sqlite3-fix-cross-compilation.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -575,6 +567,7 @@ Guile's foreign function interface.")
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
+ ("guile" ,guile-2.2)
("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.2)