summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0ee712b6f5..fe99fb9236 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2555,8 +2555,35 @@ list of components. This module takes care of that for you.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-gnu-filesystem-hierarchy")
+ #:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-references-to-extension
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((effective (read-line
+ (open-pipe* OPEN_READ
+ "guile" "-c"
+ "(display (effective-version))"))))
+ (substitute* '("module/gi.scm"
+ "module/gi/oop.scm"
+ "module/gi/documentation.scm"
+ "module/gi/types.scm"
+ "module/gi/repository.scm")
+ (("\\(load-extension \"libguile-gi\" \"(.*)\"\\)" m arg)
+ (format #f "~s"
+ `(load-extension
+ (format #f "~alibguile-gi"
+ (if (getenv "GUILE_GI_UNINSTALLED")
+ ""
+ ,(format #f "~a/lib/guile/~a/"
+ (assoc-ref outputs "out")
+ effective)))
+ ,arg)))))
+ (setenv "GUILE_GI_UNINSTALLED" "1")
+ #t))
(add-before 'check 'start-xorg-server
(lambda* (#:key inputs #:allow-other-keys)
;; The init_check test requires a running X server.
@@ -3231,3 +3258,35 @@ models and also supports a rich set of boolean query operators.")
@code{.torrent} or metainfo files. Implements a bencode reader and writer
according to Bitorrent BEP003.")
(license license:gpl3+)))
+
+(define-public guile-irc
+ (let ((commit "375d3bde9c6ae7ccc9d7cc65817966b6fda8f26a")
+ (revision "0"))
+ (package
+ (name "guile-irc")
+ (version (git-version "0.3.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rekado/guile-irc.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "113lcckcywrz9060w1c3fnvr8d7crdsjgsv4h47hgmr1slgadl4y"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-gnutls=yes")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("guile" ,guile-2.2)))
+ (home-page "https://github.com/rekado/guile-irc")
+ (synopsis "IRC library for Guile")
+ (description "This package provides a Guile library for @dfn{Internet
+Relay Chat} (IRC).")
+ ;; Some file headers incorrectly say LGPLv2+.
+ (license license:lgpl2.1+))))