summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm117
1 files changed, 86 insertions, 31 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2f974ee63b..2e9ba7bc65 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016, 2019 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 David Thompson <davet@gnu.org>
-;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2017, 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -909,7 +909,7 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
(define-public guile-email
(package
(name "guile-email")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
@@ -918,7 +918,7 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
version ".tar.lz"))
(sha256
(base32
- "0zgvh2329zrclxfb1lh7dnqrq46jj77l0lx7j9y6y3xgbhd2d9l0"))))
+ "1ph3pb69hr3d8mj05fmbpf5rc67dlm8qnb35cc7cxz8ingvl7kv3"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -936,8 +936,8 @@ format.")
(license license:agpl3+)))
(define-public guile-debbugs-next
- (let ((commit "75a331d561c8b6f8efcf16216dab961c17759efe")
- (revision "1"))
+ (let ((commit "fb0ae064037a38a0d526e08b4ad24c52e205edb9")
+ (revision "2"))
(package (inherit guile-debbugs)
(name "guile-debbugs")
(version (git-version "0.0.3" revision commit))
@@ -949,7 +949,7 @@ format.")
(file-name (git-file-name name version))
(sha256
(base32
- "0br3mgbw41bpc9x57jlghl0i8dz9nl63r4wzs5l47aqszf84870y"))))
+ "195sacx2xc1mzzfljj62nfpi8mxn0rc6dabxckizjksnhb5irfwy"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -1024,7 +1024,7 @@ microblogging service.")
(define-public guile-parted
(package
(name "guile-parted")
- (version "0.0.1")
+ (version "0.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1033,7 +1033,7 @@ microblogging service.")
(file-name (git-file-name name version))
(sha256
(base32
- "1q7425gpjlwi2wvhzq7kw046yyx7v6j6jyzkd1cr861iz34mjwiq"))))
+ "01qmv6xnbbq3wih0dl9bscvca2d7zx7bjiqf35y6dkaqsp8nvdxf"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
@@ -1591,9 +1591,6 @@ many readers as needed).")
(home-page "https://www.nongnu.org/guile-reader/")
(license license:gpl3+)))
-(define-public guile2.2-reader
- (deprecated-package "guile2.2-reader" guile-reader))
-
(define-public guile-ncurses
(package
(name "guile-ncurses")
@@ -1689,9 +1686,6 @@ for Guile\".")
(name "guile2.0-lib")
(inputs `(("guile" ,guile-2.0)))))
-(define-public guile2.2-lib
- (deprecated-package "guile2.2-lib" guile-lib))
-
(define-public guile-minikanren
(package
(name "guile-minikanren")
@@ -1728,8 +1722,11 @@ See http://minikanren.org/ for more on miniKanren generally.")
(name "guile2.0-minikanren")
(native-inputs `(("guile" ,guile-2.0)))))
-(define-public guile2.2-minikanren
- (deprecated-package "guile2.2-minikanren" guile-minikanren))
+(define-public guile3.0-minikanren
+ (package
+ (inherit guile-minikanren)
+ (name "guile3.0-minikanren")
+ (native-inputs `(("guile" ,guile-next)))))
(define-public guile-irregex
(package
@@ -1777,8 +1774,11 @@ inspired by the SCSH regular expression system.")
(name "guile2.0-irregex")
(native-inputs `(("guile" ,guile-2.0)))))
-(define-public guile2.2-irregex
- (deprecated-package "guile2.2-irregex" guile-irregex))
+(define-public guile3.0-irregex
+ (package
+ (inherit guile-irregex)
+ (name "guile3.0-irregex")
+ (native-inputs `(("guile" ,guile-next)))))
(define-public haunt
(package
@@ -1850,9 +1850,6 @@ interface for reading articles in any format.")
(name "guile2.0-haunt")
(inputs `(("guile" ,guile-2.0)))))
-(define-public guile2.2-haunt
- (deprecated-package "guile2.2-haunt" haunt))
-
(define-public guile-redis
(package
(name "guile-redis")
@@ -1883,9 +1880,6 @@ key-value cache and store.")
,@(alist-delete "guile"
(package-native-inputs guile-redis))))))
-(define-public guile2.2-redis
- (deprecated-package "guile2.2-redis" guile-redis))
-
(define-public guile-commonmark
(package
(name "guile-commonmark")
@@ -1919,9 +1913,6 @@ is no support for parsing block and inline level HTML.")
(name "guile2.0-commonmark")
(inputs `(("guile" ,guile-2.0)))))
-(define-public guile2.2-commonmark
- (deprecated-package "guile2.2-commonmark" guile-commonmark))
-
(define-public mcron
(package
(name "mcron")
@@ -2003,8 +1994,8 @@ The picture values can directly be displayed in Geiser.")
(license license:lgpl3+))))
(define-public guile-studio
- (let ((commit "e2da64f014942a73996286c4abe3c3b1f8bd220c")
- (revision "1"))
+ (let ((commit "4d63f3d684f61bf83566745e8572496cdf6daad0")
+ (revision "2"))
(package
(name "guile-studio")
(version (git-version "0" revision commit))
@@ -2015,7 +2006,7 @@ The picture values can directly be displayed in Geiser.")
(commit commit)))
(sha256
(base32
- "10v3kw41bzd8c2a6vxgrwbvl216d0k8f5s9h6pm8hahpd03jl7lm"))))
+ "1d3hhw3c3mk5i87xvfqa643674f08j1jd1rc1pl534gydz529vd5"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are none
@@ -2156,7 +2147,7 @@ chunks can be expressions as well as simple tokens.")
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(home-page "https://gitlab.com/tampe/guile-persist")
- (synopsis "Persistance programming framework for Guile")
+ (synopsis "Persistence programming framework for Guile")
(description
"This is a serialization library for serializing objects like classes
and objects, closures and structs. This currently does not support
@@ -2554,3 +2545,67 @@ Emacsy. It has a small C layer and most browser features are fully
programmable in Guile. It has hooks, keymaps, and self documentation
features.")
(license license:gpl3+)))
+
+(define-public guile-cv
+ (package
+ (name "guile-cv")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/guile-cv/guile-cv-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qdf0s2h1xj5lbhnc1pfw69i3zg08pqy2y6869b92ydfis8r82j9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'prepare-build
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("SITEDIR=\"\\$datadir/guile-cv\"")
+ "SITEDIR=\"$datadir/guile/site/$GUILE_EFFECTIVE_VERSION\"")
+ (("SITECCACHEDIR=\"\\$libdir/guile-cv/")
+ "SITECCACHEDIR=\"$libdir/"))
+ (substitute* "cv/init.scm"
+ (("\\(dynamic-link \"libvigra_c\"\\)")
+ (string-append "(dynamic-link \""
+ (assoc-ref inputs "vigra-c")
+ "/lib/libvigra_c\")"))
+ (("\\(dynamic-link \"libguile-cv\"\\)")
+ (format #f "~s"
+ `(dynamic-link
+ (format #f "~alibguile-cv"
+ (if (getenv "GUILE_CV_UNINSTALLED")
+ ""
+ ,(format #f "~a/lib/"
+ (assoc-ref outputs "out"))))))))
+ (setenv "GUILE_CV_UNINSTALLED" "1")
+ ;; Only needed to satisfy the configure script.
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (assoc-ref inputs "vigra-c") "/lib"))
+ #t)))))
+ (inputs
+ `(("vigra" ,vigra)
+ ("vigra-c" ,vigra-c)
+ ("guile" ,guile-2.2)))
+ (native-inputs
+ `(("texlive" ,(texlive-union (list texlive-booktabs
+ texlive-lm
+ texlive-siunitx
+ texlive-standalone
+ texlive-xcolor
+ texlive-fonts-iwona)))
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("guile-lib" ,guile-lib)))
+ (home-page "https://www.gnu.org/software/guile-cv/")
+ (synopsis "Computer vision library for Guile")
+ (description "Guile-CV is a Computer Vision functional programming library
+for the Guile Scheme language. It is based on Vigra (Vision with Generic
+Algorithms), a C++ image processing and analysis library. Guile-CV contains
+bindings to Vigra C (a C wrapper to most of the Vigra functionality) and is
+enriched with pure Guile Scheme algorithms, all accessible through a nice,
+clean and easy to use high level API.")
+ (license license:gpl3+)))