summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm76
1 files changed, 70 insertions, 6 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2f974ee63b..2736b36a38 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -909,7 +909,7 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
(define-public guile-email
(package
(name "guile-email")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
@@ -918,7 +918,7 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
version ".tar.lz"))
(sha256
(base32
- "0zgvh2329zrclxfb1lh7dnqrq46jj77l0lx7j9y6y3xgbhd2d9l0"))))
+ "1ph3pb69hr3d8mj05fmbpf5rc67dlm8qnb35cc7cxz8ingvl7kv3"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -936,8 +936,8 @@ format.")
(license license:agpl3+)))
(define-public guile-debbugs-next
- (let ((commit "75a331d561c8b6f8efcf16216dab961c17759efe")
- (revision "1"))
+ (let ((commit "fb0ae064037a38a0d526e08b4ad24c52e205edb9")
+ (revision "2"))
(package (inherit guile-debbugs)
(name "guile-debbugs")
(version (git-version "0.0.3" revision commit))
@@ -949,7 +949,7 @@ format.")
(file-name (git-file-name name version))
(sha256
(base32
- "0br3mgbw41bpc9x57jlghl0i8dz9nl63r4wzs5l47aqszf84870y"))))
+ "195sacx2xc1mzzfljj62nfpi8mxn0rc6dabxckizjksnhb5irfwy"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -2156,7 +2156,7 @@ chunks can be expressions as well as simple tokens.")
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(home-page "https://gitlab.com/tampe/guile-persist")
- (synopsis "Persistance programming framework for Guile")
+ (synopsis "Persistence programming framework for Guile")
(description
"This is a serialization library for serializing objects like classes
and objects, closures and structs. This currently does not support
@@ -2554,3 +2554,67 @@ Emacsy. It has a small C layer and most browser features are fully
programmable in Guile. It has hooks, keymaps, and self documentation
features.")
(license license:gpl3+)))
+
+(define-public guile-cv
+ (package
+ (name "guile-cv")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/guile-cv/guile-cv-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qdf0s2h1xj5lbhnc1pfw69i3zg08pqy2y6869b92ydfis8r82j9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'prepare-build
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("SITEDIR=\"\\$datadir/guile-cv\"")
+ "SITEDIR=\"$datadir/guile/site/$GUILE_EFFECTIVE_VERSION\"")
+ (("SITECCACHEDIR=\"\\$libdir/guile-cv/")
+ "SITECCACHEDIR=\"$libdir/"))
+ (substitute* "cv/init.scm"
+ (("\\(dynamic-link \"libvigra_c\"\\)")
+ (string-append "(dynamic-link \""
+ (assoc-ref inputs "vigra-c")
+ "/lib/libvigra_c\")"))
+ (("\\(dynamic-link \"libguile-cv\"\\)")
+ (format #f "~s"
+ `(dynamic-link
+ (format #f "~alibguile-cv"
+ (if (getenv "GUILE_CV_UNINSTALLED")
+ ""
+ ,(format #f "~a/lib/"
+ (assoc-ref outputs "out"))))))))
+ (setenv "GUILE_CV_UNINSTALLED" "1")
+ ;; Only needed to satisfy the configure script.
+ (setenv "LD_LIBRARY_PATH"
+ (string-append (assoc-ref inputs "vigra-c") "/lib"))
+ #t)))))
+ (inputs
+ `(("vigra" ,vigra)
+ ("vigra-c" ,vigra-c)
+ ("guile" ,guile-2.2)))
+ (native-inputs
+ `(("texlive" ,(texlive-union (list texlive-booktabs
+ texlive-lm
+ texlive-siunitx
+ texlive-standalone
+ texlive-xcolor
+ texlive-fonts-iwona)))
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("guile-lib" ,guile-lib)))
+ (home-page "https://www.gnu.org/software/guile-cv/")
+ (synopsis "Computer vision library for Guile")
+ (description "Guile-CV is a Computer Vision functional programming library
+for the Guile Scheme language. It is based on Vigra (Vision with Generic
+Algorithms), a C++ image processing and analysis library. Guile-CV contains
+bindings to Vigra C (a C wrapper to most of the Vigra functionality) and is
+enriched with pure Guile Scheme algorithms, all accessible through a nice,
+clean and easy to use high level API.")
+ (license license:gpl3+)))