summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm109
1 files changed, 108 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5dfe20f523..38ad05e074 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -22,8 +22,16 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages icu4c)
+ #:use-module (gnu packages libpng)
+ #:use-module (gnu packages pdf)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xorg))
(define-public atk
(package
@@ -46,3 +54,102 @@ by other toolkits and applications. Using the ATK interfaces, accessibility
tools have full access to view and control running applications.")
(license license:lgpl2.0+)
(home-page "https://developer.gnome.org/atk/")))
+
+(define-public cairo
+ (package
+ (name "cairo")
+ (version "1.12.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://cairographics.org/releases/cairo-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "04xcykglff58ygs0dkrmmnqljmpjwp2qgwcz8sijqkdpz7ix3l4n"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("glib" ,glib)
+ ("libpng" ,libpng)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxrender" ,libxrender)
+ ("pixman" ,pixman)))
+ (inputs
+ `(("ghostscript" ,ghostscript)
+ ("libspectre" ,libspectre)
+ ("pkg-config" ,pkg-config)
+ ("poppler" ,poppler)
+ ("python" ,python)
+ ("xextproto" ,xextproto)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f)) ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
+ (synopsis "2D graphics library")
+ (description
+ "Cairo is a 2D graphics library with support for multiple output devices.
+Currently supported output targets include the X Window System (via both
+Xlib and XCB), Quartz, Win32, image buffers, PostScript, PDF, and SVG file
+output. Experimental backends include OpenGL, BeOS, OS/2, and DirectFB.
+
+Cairo is designed to produce consistent output on all output media while
+taking advantage of display hardware acceleration when available
+eg. through the X Render Extension).
+
+The cairo API provides operations similar to the drawing operators of
+PostScript and PDF. Operations in cairo including stroking and filling cubic
+Bézier splines, transforming and compositing translucent images, and
+antialiased text rendering. All drawing operations can be transformed by any
+affine transformation (scale, rotation, shear, etc.)")
+ (license license:lgpl2.1) ; or Mozilla Public License 1.1
+ (home-page "http://cairographics.org/")))
+
+(define-public harfbuzz
+ (package
+ (name "harfbuzz")
+ (version "0.9.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "026rlwspf1zn5akds9fwibpqpn47kmlnmqm5fi0cp4k4dnygpw7y"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("icu4c" ,icu4c)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (synopsis "opentype text shaping engine")
+ (description
+ "HarfBuzz is an OpenType text shaping engine.")
+ (license (license:x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))
+ (home-page "http://www.freedesktop.org/wiki/Software/HarfBuzz/")))
+
+(define-public pango
+ (package
+ (name "pango")
+ (version "1.34.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pango/1.34/pango-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0k7662qix7zzh7mf6ikdj594n8jpbfm25z8swz64zbm86kgk1shs"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("cairo" ,cairo)
+ ("harfbuzz" ,harfbuzz)
+ ("pkg-config" ,pkg-config)
+ ("zlib" ,zlib)))
+ (synopsis "GNOME text and font handling library")
+ (description
+ "Pango is the core text and font handling library used in GNOME
+applications. It has extensive support for the different writing systems
+used throughout the world.")
+ (license license:lgpl2.0+)
+ (home-page "https://developer.gnome.org/pango/")))