summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm72
1 files changed, 52 insertions, 20 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a3e19827f5..b136449f7e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -145,7 +145,8 @@ tools have full access to view and control running applications.")
("python" ,python-wrapper)))
(arguments
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
- #:configure-flags '("--enable-tee"))) ; needed for GNU Icecat
+ #:configure-flags '("--enable-tee" ;needed for GNU Icecat
+ "--disable-static")))
(synopsis "2D graphics library")
(description
"Cairo is a 2D graphics library with support for multiple output devices.
@@ -181,7 +182,7 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public harfbuzz
(package
(name "harfbuzz")
- (version "2.5.3")
+ (version "2.6.4")
(source (origin
(method url-fetch)
(uri (string-append "https://www.freedesktop.org/software/"
@@ -189,7 +190,7 @@ affine transformation (scale, rotation, shear, etc.).")
version ".tar.xz"))
(sha256
(base32
- "0p45xk5bblsw8lfs7y7z80b4rvda9f2hlpr28flkrfmpjz3hvl7y"))))
+ "04iwq13w6zkdhljmsxrzgg4fyh04qnwfn57rgrl9kmijc7cvh4wl"))))
(build-system gnu-build-system)
(outputs '("out"
"bin")) ; 160K, only hb-view depend on cairo
@@ -221,16 +222,28 @@ affine transformation (scale, rotation, shear, etc.).")
(define-public pango
(package
(name "pango")
- (version "1.42.4")
+ (version "1.44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/pango/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "pango-skip-libthai-test.patch"))
(sha256
(base32
- "17bwb7dgbncrfsmchlib03k9n3xaalirb39g3yb43gg8cg6p8aqx"))))
- (build-system gnu-build-system)
+ "07qvxa2sk90chp1l12han6vxvy098mc37sdqcznyywyv2g6bd9b6"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-cantarell-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; XXX FIXME: These tests require "font-cantarell", but
+ ;; adding it here would introduce a circular dependency.
+ (("\\[ 'test-harfbuzz'.*") "")
+ (("\\[ 'test-itemize'.*") "")
+ (("\\[ 'test-layout'.*") ""))
+ #t)))))
(propagated-inputs
;; These are all in Requires or Requires.private of the '.pc' files.
`(("cairo" ,cairo)
@@ -238,13 +251,13 @@ affine transformation (scale, rotation, shear, etc.).")
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("glib" ,glib)
- ("harfbuzz" ,harfbuzz)))
- (inputs
- `(("zlib" ,zlib)
+ ("harfbuzz" ,harfbuzz)
;; Some packages, such as Openbox, expect Pango to be built with the
;; optional libxft support.
("libxft" ,libxft)))
+ (inputs
+ `(("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
@@ -257,6 +270,21 @@ used throughout the world.")
(license license:lgpl2.0+)
(home-page "https://developer.gnome.org/pango/")))
+(define-public pango-1.42
+ (package/inherit
+ pango
+ (version "1.42.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pango/"
+ (version-major+minor version) "/"
+ "pango-" version ".tar.xz"))
+ (sha256
+ (base32
+ "17bwb7dgbncrfsmchlib03k9n3xaalirb39g3yb43gg8cg6p8aqx"))))
+ (build-system gnu-build-system)
+ (arguments '())))
+
(define-public pangox-compat
(package
(name "pangox-compat")
@@ -671,7 +699,7 @@ is part of the GNOME accessibility project.")
"gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch"
"gtk2-theme-paths.patch"))))
(build-system gnu-build-system)
- (outputs '("out" "doc"))
+ (outputs '("out" "bin" "doc"))
(propagated-inputs
`(("atk" ,atk)
("gdk-pixbuf" ,gdk-pixbuf+svg)
@@ -698,14 +726,19 @@ is part of the GNOME accessibility project.")
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
#:phases
- (alist-cons-before
- 'configure 'disable-tests
- (lambda _
- ;; FIXME: re-enable tests requiring an X server
- (substitute* "gtk/Makefile.in"
- (("SUBDIRS = theme-bits . tests") "SUBDIRS = theme-bits ."))
- #t)
- %standard-phases)))
+ (modify-phases %standard-phases
+ (add-before 'configure 'disable-tests
+ (lambda _
+ ;; FIXME: re-enable tests requiring an X server
+ (substitute* "gtk/Makefile.in"
+ (("SUBDIRS = theme-bits . tests") "SUBDIRS = theme-bits ."))
+ #t))
+ (add-after 'install 'remove-cache
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each
+ delete-file
+ (find-files (assoc-ref outputs "out") "immodules.cache"))
+ #t)))))
(native-search-paths
(list (search-path-specification
(variable "GUIX_GTK2_PATH")
@@ -733,7 +766,6 @@ application suites.")
"1a9hi7k59q0kqx0n3xhsk1ly23w9g9ncllnay1756g0yrww5qxsc"))
(patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"
"gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch"))))
- (outputs '("out" "bin" "doc"))
(propagated-inputs
`(("at-spi2-atk" ,at-spi2-atk)
("atk" ,atk)