summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0a6499d293..0cbd55dd52 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -404,7 +404,13 @@ application suites.")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)
- ("xorg-server" ,xorg-server)))
+
+ ;; FIXME: The Xorg server is needed to run the tests, but it currently
+ ;; fails to build on mips64el, so remove it in the meantime.
+ ,@(if (string=? (or (%current-target-system) (%current-system))
+ "mips64el-linux")
+ '()
+ `(("xorg-server" ,xorg-server)))))
(arguments
`(#:phases
(alist-replace