summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index e3019f630c..977ca14e3a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages pkg-config)
@@ -262,7 +263,8 @@ developers consider to have good quality code and correct functionality.")
"1g7vg9amh3cc3nmc415h6g2rqxqi4wgwqi08hxfbpwq48ri64p30"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags '("--with-system-libav")
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
(lambda _
@@ -271,10 +273,10 @@ developers consider to have good quality code and correct functionality.")
(string-append "#! "(which "sh")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python" ,python)
- ("yasm" ,yasm)))
+ ("python" ,python)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
+ ("ffmpeg" ,ffmpeg)
("orc" ,orc)
("zlib" ,zlib)))
(home-page "http://gstreamer.freedesktop.org/")