summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 16ab9d20a4..97dff5b3b9 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -299,7 +299,7 @@ many more.")
(define-public ilmbase
(package
(name "ilmbase")
- (version "2.4.1")
+ (version "2.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -308,9 +308,9 @@ many more.")
(file-name (git-file-name "ilmbase" version))
(sha256
(base32
- "020gyl8zv83ag6gbcchmqiyx9rh2jca7j8n52zx1gk4rck7kwc01"))
+ "1k50cvi3sk6gf6w713lkk2gv5cvs74vkc7s7k4z6nmyhi4g89w4y"))
(patches (search-patches "ilmbase-fix-tests.patch"
- "ilmbase-openexr-pkg-config.patch"))))
+ "ilmbase-fix-test-arm.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -426,10 +426,7 @@ graphics.")
;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
(lambda _
(substitute* "IlmImfTest/main.cpp"
- ((".*testOptimizedInterleavePatterns.*") "")
- ;; This test is broken in 2.4.0 and will be fixed in a later
- ;; release: <https://github.com/openexr/openexr/issues/571>.
- ((".*testLargeDataWindowOffsets.*") ""))
+ ((".*testOptimizedInterleavePatterns.*") ""))
#t)))
'()))))
(native-inputs