summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm36
1 files changed, 25 insertions, 11 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f9baf49fe9..94a797c8f5 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
@@ -78,20 +78,18 @@
#:use-module (guix utils))
(define-public blender
- (let ((revision "0")
- (commit "3c3d80ea22af15e13237f978181a881b90c41e7c"))
(package
(name "blender")
- (version (git-version "2.80-beta" revision commit))
+ (version "v2.80-rc1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://git.blender.org/blender.git")
- (commit commit)))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1hhn8pf3a5556mxyrb2ggsiy6q0h75hnkdpcgq9b6vg284jl2l4q"))))
+ "11dcf0rjq42mpphk8r8cy7gvhzzl1cj1vslp98ibh8sdjzaz2mdq"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
@@ -166,8 +164,8 @@ the 3D pipeline—modeling, rigging, animation, simulation, rendering,
compositing and motion tracking, even video editing and game creation. The
application can be customized via its API for Python scripting.
-WARNING: This is a beta build of Blender.")
- (license license:gpl2+))))
+WARNING: This is a release candidate build of Blender.")
+ (license license:gpl2+)))
(define-public blender-2.79
(package
@@ -230,7 +228,7 @@ WARNING: This is a beta build of Blender.")
`(("boost" ,boost)
("jemalloc" ,jemalloc)
("libx11" ,libx11)
- ("openimageio" ,openimageio)
+ ("openimageio" ,openimageio-1.7)
("openexr" ,openexr)
("ilmbase" ,ilmbase)
("openjpeg" ,openjpeg-1)
@@ -456,7 +454,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
(define-public openimageio
(package
(name "openimageio")
- (version "1.7.19")
+ (version "1.8.17")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -465,7 +463,7 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
(file-name (git-file-name name version))
(sha256
(base32
- "0yxxy43l3lllw7maqg42dlkgqms2d4772sxzxk7kmxg4lnhsvndc"))))
+ "0zq34szprgkrrayg5sl3whrsx2l6lr8nw4hdrnwv2qhn70jbi2w2"))))
(build-system cmake-build-system)
;; FIXME: To run all tests successfully, test image sets from multiple
;; third party sources have to be present. For details see
@@ -492,6 +490,22 @@ visual effects work for film.")
(home-page "http://www.openimageio.org")
(license license:bsd-3)))
+;; This older version of OpenImageIO is required for Blender 2.79.
+(define-public openimageio-1.7
+ (package
+ (inherit openimageio)
+ (name "openimageio")
+ (version "1.7.19")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenImageIO/oiio.git")
+ (commit (string-append "Release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yxxy43l3lllw7maqg42dlkgqms2d4772sxzxk7kmxg4lnhsvndc"))))))
+
(define-public openscenegraph
(package
(name "openscenegraph")