summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm90
1 files changed, 67 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 76b93c0d14..f94251abaf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1128,33 +1128,31 @@ incoming requests with their respective handler.")
(license license:asl2.0))))
(define-public go-github-com-spf13-pflag
- (let ((commit "4f9190456aed1c2113ca51ea9b89219747458dc1")
- (revision "0"))
- (package
- (name "go-github-com-spf13-pflag")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spf13/pflag.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12vrlcsbwjqlfc49rwky45mbcj74c0kb6z54354pzas6fwzyi1kc"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/spf13/pflag"))
- (home-page "https://github.com/spf13/pflag")
- (synopsis "Replacement for Go's @code{flag} package")
- (description
- "Pflag is library to replace Go's @code{flag} package. It implements
+ (package
+ (name "go-github-com-spf13-pflag")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spf13/pflag.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gpmacngd0gpslnbkzi263f5ishigzgh6pbdv9hp092rnjl4nd31"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/spf13/pflag"))
+ (home-page "https://github.com/spf13/pflag")
+ (synopsis "Replacement for Go's @code{flag} package")
+ (description
+ "Pflag is library to replace Go's @code{flag} package. It implements
POSIX/GNU-style command-line options with double hyphens. It is is compatible
with the
@uref{https://www.gnu.org/software/libc/manual/html_node/Argument-Syntax.html,
GNU extensions} to the POSIX recommendations for command-line options.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public go-github-com-sirupsen-logrus
(package
@@ -3036,3 +3034,49 @@ on running processes and system utilization (CPU, memory, disks, network,
sensors).")
(home-page "https://github.com/shirou/gopsutil")
(license license:bsd-3))))
+
+(define-public go-github-com-fatih-color
+ (package
+ (name "go-github-com-fatih-color")
+ (version "1.8.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fatih/color.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zc0zlilf03h121f9jqq3ar0hfm7706547zysxp2qxbm920pz7h0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/fatih/color"))
+ (synopsis "Print colored text in Go")
+ (description "This package provides an ANSI color package to output
+colorized or SGR defined output to the standard output.")
+ (home-page "https://godoc.org/github.com/fatih/color")
+ (license license:expat)))
+
+(define-public go-github-com-google-go-cmp-cmp
+ (package
+ (name "go-github-com-google-go-cmp-cmp")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-cmp.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1caw49i0plkjxir7kdf5qhwls3krqwfmi7g4h392rdfwi3kfahx1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/google/go-cmp/cmp"
+ #:unpack-path "github.com/google/go-cmp"))
+ (synopsis "Determine equality of values in Go")
+ (description "This package provides a more powerful and safer
+alternative to @code{reflect.DeepEqual} for comparing whether two values
+are semantically equal in Go (for writing tests).")
+ (home-page "https://godoc.org/github.com/google/go-cmp/cmp")
+ (license license:asl2.0)))