summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 522404f280..7caa7314a9 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -124,7 +124,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.18")
+ (version "3.19.1")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -135,7 +135,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "0h0xy9kvd2s8r438q4dfn25cgvv5dc1hkm9lb4bgrxpr5bxv13b1"))
+ "1zrgqlli01gsg2a5w4bk2p0q3aagi5dhd31yirnj04zca6ap1gmp"))
;; Create nss.pc and nss-config.
(patches (list (search-patch "nss-pkgconfig.patch")))))
(build-system gnu-build-system)
@@ -205,6 +205,12 @@ in the Mozilla clients.")
("zlib" ,zlib)))
(propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
(native-inputs `(("perl" ,perl)))
+
+ ;; The NSS test suite takes over 28 hours on Loongson 3A (MIPS), and
+ ;; possibly longer when another build is happening concurrently on the
+ ;; same machine.
+ (properties '((timeout . 144000))) ; 40 hours
+
(home-page
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
(synopsis "Network Security Services")
@@ -219,7 +225,7 @@ standards.")
(define-public icecat
(package
(name "icecat")
- (version "31.6.0-gnu1")
+ (version "31.7.0-gnu1")
(source
(origin
(method url-fetch)
@@ -228,15 +234,13 @@ standards.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1a4l23msg4cpc4yp59q2z6xv63r6advlbnjy65v4djv6yhgnqf1i"))))
+ "0a25jp5afla2dxzj7i4cyvqpa5smsn7ns3xvpzqw6pc7naixkpap"))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
("bzip2" ,bzip2)
("cairo" ,cairo)
- ("dbus" ,dbus)
("dbus-glib" ,dbus-glib)
- ("glib" ,glib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+-2)