summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm35
1 files changed, 22 insertions, 13 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 18ed6f9714..3f3964e74b 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -66,7 +66,9 @@
for all GnuPG components. Among these are GPG, GPGSM, GPGME,
GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard
Daemon and possibly more in the future.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (properties '((ftp-server . "ftp.gnupg.org")
+ (ftp-directory . "/gcrypt/libgpg-error")))))
(define-public libgcrypt
(package
@@ -100,7 +102,9 @@ Daemon and possibly more in the future.")
standard cryptographic building blocks such as symmetric ciphers, hash
algorithms, public key algorithms, large integer functions and random number
generation.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (properties '((ftp-server . "ftp.gnupg.org")
+ (ftp-directory . "/gcrypt/libgcrypt")))))
(define-public libgcrypt-1.5
(package (inherit libgcrypt)
@@ -137,7 +141,9 @@ generation.")
protocol. This protocol is used for IPC between most newer
GnuPG components. Both, server and client side functions are
provided.")
- (license license:lgpl2.0+)))
+ (license license:lgpl2.0+)
+ (properties '((ftp-server . "ftp.gnupg.org")
+ (ftp-directory . "/gcrypt/libassuan")))))
(define-public libksba
(package
@@ -170,7 +176,9 @@ provided.")
"KSBA (pronounced Kasbah) is a library to make X.509 certificates
as well as the CMS easily accessible by other applications. Both
specifications are building blocks of S/MIME and TLS.")
- (license license:gpl3+)))
+ (license license:gpl3+)
+ (properties '((ftp-server . "ftp.gnupg.org")
+ (ftp-directory . "/gcrypt/libksba")))))
(define-public npth
(package
@@ -208,9 +216,8 @@ compatible to GNU Pth.")
(sha256
(base32
"06mn2viiwsyq991arh5i5fhr9jyxq2bi0jkdj7ndfisxihngpc5p"))
- (patches
- (list (search-patch
- "gnupg-simple-query-ignore-status-messages.patch")))))
+ (patches (search-patches
+ "gnupg-simple-query-ignore-status-messages.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -245,7 +252,9 @@ features powerful key management and the ability to access public key
servers. It includes several libraries: libassuan (IPC between GnuPG
components), libgpg-error (centralized GnuPG error values), and
libskba (working with X.509 certificates and CMS data).")
- (license license:gpl3+)))
+ (license license:gpl3+)
+ (properties '((ftp-server . "ftp.gnupg.org")
+ (ftp-directory . "/gcrypt/gnupg")))))
(define-public gnupg-2.0
(package (inherit gnupg)
@@ -352,7 +361,7 @@ and every application benefits from this.")
;; Unfortunately, we have to disable some tests due to some gpg-agent
;; goofiness... see:
;; https://bugs.launchpad.net/pygpgme/+bug/999949
- (patches (list (search-patch "pygpgme-disable-problematic-tests.patch")))))
+ (patches (search-patches "pygpgme-disable-problematic-tests.patch"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -563,14 +572,14 @@ including tools for signing keys, keyring analysis, and party preparation.
(define-public pinentry
(package
(name "pinentry")
- (version "0.9.6")
+ (version "0.9.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/pinentry/pinentry-"
version ".tar.bz2"))
(sha256
(base32
- "0rhyw1vk28kgasjp22myf7m2q8kycw82d65pr9kgh93z17lj849a"))))
+ "1cp7wjqr6nx31mdclr61s2h84ijqjl0ph99kgj4vyawpjj1j1633"))))
(build-system gnu-build-system)
(inputs
`(("ncurses" ,ncurses)
@@ -580,7 +589,7 @@ including tools for signing keys, keyring analysis, and party preparation.
("glib" ,glib)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "http://gnupg.org/aegypten2/")
+ (home-page "https://gnupg.org/aegypten2/")
(synopsis "GnuPG's interface to passphrase input")
(description
"Pinentry provides a console and a GTK+ GUI that allows users to