summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm85
1 files changed, 37 insertions, 48 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index dc801a6a4f..befd29961c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -217,18 +217,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.1.17")
+ (version "2.1.18")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "1js308b46ifx1gim0c9nivr5yxhans7iq1yvkf7zl2928gdm9p65"))
- (patches
- ;; This fixes a test failure on 32bit. Remove for next version.
- ;; https://lists.gnu.org/archive/html/guix-devel/2016-12/msg00869.html
- (search-patches "gnupg-test-segfault-on-32bit-arch.patch"))))
+ "157rrv3ly9j2k0acz43nhiba5hfl6h7048jvj55wwqjmgsmnyk6h"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -310,7 +306,7 @@ libskba (working with X.509 certificates and CMS data).")
(add-before 'configure 'patch-config-files
(lambda _
(substitute* "tests/openpgp/Makefile.in"
- (("/bin/sh") (which "bash")))
+ (("/bin/sh") (which "sh")))
#t))
(add-after 'install 'rename-v2-commands
(lambda* (#:key outputs #:allow-other-keys)
@@ -349,7 +345,7 @@ libskba (working with X.509 certificates and CMS data).")
(add-after 'unpack 'patch-check-sh
(lambda _
(substitute* "checks/Makefile.in"
- (("/bin/sh") (which "bash"))))))))))
+ (("/bin/sh") (which "sh"))))))))))
(define-public gpgme
(package
@@ -500,43 +496,36 @@ and signature functionality from Python programs.")
(package-with-python2 python-gnupg))
(define-public pius
- ;; pius 2.2.2 does not work with gpg-agent 2.1, so we take a newer
- ;; commit. When a new pius (> 2.2.2) is released, update this package
- ;; and delete this message.
- ;; More info: https://github.com/jaymzh/pius/issues/46
- (let ((commit "891687ccb3d232a1fc0e7da7d22572c0318644cb")
- (base-version "2.2.2")) ; i.e. there were no releases
- ; between BASE-VERSION and COMMIT
- (package
- (name "pius")
- (version (string-append base-version "-0."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jaymzh/pius.git")
- (commit commit)))
- (sha256
- (base32
- "0m2na4bnf1rv0zpf404l9ga6pwyf7ijldp4lw5irgh7gkmpllxr3"))))
- (build-system python-build-system)
- (inputs `(("perl" ,perl) ;for 'pius-party-worksheet'
- ("gpg" ,gnupg)))
- (arguments
- `(#:tests? #f
- #:python ,python-2 ;uses the Python 2 'print' syntax
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'set-gpg-file-name
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((gpg (string-append (assoc-ref inputs "gpg")
- "/bin/gpg")))
- (substitute* "libpius/constants.py"
- (("/usr/bin/gpg2") gpg))))))))
- (synopsis "Programs to simplify GnuPG key signing")
- (description
- "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
+ (package
+ (name "pius")
+ (version "2.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/jaymzh/pius/releases/download/v"
+ version "/pius-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0iy0gnms6lv9hpvk29313kc495a2f7pq2mg6ljxhy233vxsmjsk6"))))
+ (build-system python-build-system)
+ (inputs `(("perl" ,perl) ;for 'pius-party-worksheet'
+ ("gpg" ,gnupg)))
+ (arguments
+ `(#:tests? #f
+ #:python ,python-2 ;uses the Python 2 'print' syntax
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'build 'set-gpg-file-name
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((gpg (string-append (assoc-ref inputs "gpg")
+ "/bin/gpg")))
+ (substitute* "libpius/constants.py"
+ (("/usr/bin/gpg2") gpg))
+ #t))))))
+ (synopsis "Programs to simplify GnuPG key signing")
+ (description
+ "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
parties. It is the main utility and makes it possible to quickly and easily
sign each UID on a set of PGP keys. It is designed to take the pain out of
the sign-all-the-keys part of PGP Keysigning Party while adding security
@@ -544,8 +533,8 @@ to the process.
pius-keyring-mgr and pius-party-worksheet help organisers of
PGP keysigning parties.")
- (license license:gpl2)
- (home-page "https://www.phildev.net/pius/index.shtml"))))
+ (license license:gpl2)
+ (home-page "https://www.phildev.net/pius/index.shtml")))
(define-public signing-party
(package
@@ -573,7 +562,7 @@ PGP keysigning parties.")
(substitute* "keyanalyze/Makefile"
(("./configure") (string-append "./configure --prefix=" out)))
(substitute* "keyanalyze/pgpring/configure"
- (("/bin/sh") (which "bash")))
+ (("/bin/sh") (which "sh")))
(substitute* "gpgwrap/Makefile"
(("\\} clean")
(string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "