summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm83
1 files changed, 70 insertions, 13 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index d6f0722f6e..c6af5caa49 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -32,7 +32,10 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages openldap)
#:use-module (gnu packages perl)
#:use-module (gnu packages pth)
@@ -53,6 +56,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python))
(define-public libgpg-error
@@ -216,14 +220,14 @@ compatible to GNU Pth.")
(define-public gnupg
(package
(name "gnupg")
- (version "2.2.0")
+ (version "2.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnupg/gnupg/gnupg-" version
".tar.bz2"))
(sha256
(base32
- "1rj538kp3wsdq7rhl8sy1wpwhlsbxcch0cwk64kgz8gpw05lllfl"))))
+ "1yv2pwf3vhv9dpbf51fnm0wy03va1cg5r7qaz7rg75cwbgb0rmrl"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -535,6 +539,43 @@ and signature functionality from Python programs.")
(define-public python2-gnupg
(package-with-python2 python-gnupg))
+(define-public perl-gnupg-interface
+ (package
+ (name "perl-gnupg-interface")
+ (version "0.52")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AL/ALEXMV/GnuPG-Interface-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dgx8yhdsmhkazcrz14n4flrk1afv7azgl003hl4arxvi1d9yyi4"))))
+ (build-system perl-build-system)
+ (arguments
+ '(;; Result: FAIL
+ ;; Failed 10/20 test programs. 21/52 subtests failed.
+ #:tests? #f))
+ (native-inputs
+ `(("perl-module-install" ,perl-module-install)
+ ("which" ,which)))
+ (inputs
+ `(("gnupg" ,gnupg)))
+ (propagated-inputs
+ `(("perl-moo" ,perl-moo)
+ ("perl-moox-late" ,perl-moox-late)
+ ("perl-moox-handlesvia" ,perl-moox-handlesvia)))
+ (home-page "http://search.cpan.org/~alexmv/GnuPG-Interface/")
+ (synopsis "Perl interface to GnuPG")
+ (description
+ "@code{GnuPG::Interface} and its associated modules are designed to
+provide an object-oriented method for interacting with GnuPG, being able to
+perform functions such as but not limited to encrypting, signing, decryption,
+verification, and key-listing parsing.")
+ (license license:perl-license)))
+
(define-public pius
(package
(name "pius")
@@ -579,38 +620,48 @@ PGP keysigning parties.")
(define-public signing-party
(package
(name "signing-party")
- (version "1.1.4")
+ (version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://debian/pool/main/s/signing-party/"
"signing-party_" version ".orig.tar.gz"))
(sha256 (base32
- "188gp0prbh8qs29lq3pbf0qibfd6jq4fk7i0pfrybl8aahvm84rx"))))
+ "1n5bpcfpl9vg1xp6r1jhbyahrgdyxp05b5pria1rh4m0qnv8sifr"))))
(build-system gnu-build-system)
- (inputs `(("perl" ,perl)))
+ (native-inputs
+ `(("autoconf" ,(autoconf-wrapper))
+ ("automake" ,automake)))
+ (inputs `(("perl" ,perl)
+ ("perl-text-template" ,perl-text-template)
+ ("perl-mime-tools" ,perl-mime-tools)
+ ("perl-gnupg-interface" ,perl-gnupg-interface)
+ ("perl-net-idn-encode" ,perl-net-idn-encode)
+ ("libmd" ,libmd)))
(arguments
`(#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-spurious-links
- (lambda _ (delete-file "keyanalyze/pgpring/depcomp")))
+ (add-before 'configure 'change-directory
+ (lambda _
+ ;; The build system in the unpack phase changes to a less useful
+ ;; subdirectory, so move up one level
+ (chdir (dirname (getcwd)))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "keyanalyze/Makefile"
(("LDLIBS") (string-append "CC=" (which "gcc") "\nLDLIBS")))
(substitute* "keyanalyze/Makefile"
- (("./configure") (string-append "./configure --prefix=" out)))
- (substitute* "keyanalyze/pgpring/configure"
- (("/bin/sh") (which "sh")))
- (substitute* "gpgwrap/Makefile"
+ (("\\./configure") (string-append "./configure --prefix=" out)))
+ (substitute* "gpgwrap/src/Makefile"
(("\\} clean")
(string-append "} clean\ninstall:\n\tinstall -D bin/gpgwrap "
out "/bin/gpgwrap\n")))
(substitute* '("gpgsigs/Makefile" "keyanalyze/Makefile"
"keylookup/Makefile" "sig2dot/Makefile"
"springgraph/Makefile")
- (("/usr") out)))))
+ (("/usr") out))
+ (setenv "CONFIG_SHELL" (which "sh")))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys #:rest args)
(let ((out (assoc-ref outputs "out"))
@@ -635,7 +686,13 @@ PGP keysigning parties.")
'("caff.1" "pgp-clean.1" "pgp-fixkey.1" "gpgdir.1"
"gpg-key2ps.1" "gpglist.1" "gpg-mailkeys.1"
"gpgparticipants.1" "gpgsigs.1" "gpgwrap.1"
- "process_keys.1" "pgpring.1" "keyanalyze.1"))))))))
+ "process_keys.1" "pgpring.1" "keyanalyze.1")))))
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program
+ (string-append out "/bin/caff")
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
(synopsis "Collection of scripts for simplifying gnupg key signing")
(description
"Signing-party is a collection for all kinds of PGP/GnuPG related things,