summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 31 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eebb547de3..5c2cf0197e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
+;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4208,7 +4209,7 @@ users.")
(define-public network-manager
(package
(name "network-manager")
- (version "1.0.10")
+ (version "1.0.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/NetworkManager/"
@@ -4216,7 +4217,7 @@ users.")
"NetworkManager-" version ".tar.xz"))
(sha256
(base32
- "1g4z2wg036n0njqp8fycrisj46l3yda6pl00l4rg9nfz862cxkqv"))))
+ "17jan0g5jzp8mrpklyacwdgnnw016m1c5pc4az5im6qhc260yirs"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 8 MiB of gtk-doc HTML
@@ -4928,3 +4929,31 @@ command-line interface. It can record part or all of an X display for a
specified duration and save it as a GIF encoded animated image file.")
(home-page "https://git.gnome.org/browse/byzanz")
(license license:gpl2+))))
+
+(define-public libzapojit
+ (package
+ (name "libzapojit")
+ (version "0.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0zn3s7ryjc3k1abj4k55dr2na844l451nrg9s6cvnnhh569zj99x"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnome-online-accounts" ,gnome-online-accounts)
+ ("json-glib" ,json-glib)
+ ("rest" ,rest)))
+ (home-page "https://wiki.gnome.org/Projects/Zapojit")
+ (synopsis "Library for accessing SkyDrive and Hotmail")
+ (description
+ "Libzapojit is a GLib-based library for accessing online service APIs of
+Microsoft SkyDrive and Hotmail, using their REST protocols.")
+ (license license:lgpl2.1+)))