summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 39f373d7a8..7d86ee5f03 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6298,7 +6298,7 @@ devices using the GNOME desktop.")
(define-public gnome-control-center
(package
(name "gnome-control-center")
- (version "3.30.3")
+ (version "3.32.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -6306,9 +6306,7 @@ devices using the GNOME desktop.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0gih1cmqbv803kp30704sllghb0impa0mmv3j8pndfg4zr2mnq9r"))
- (patches
- (search-patches "gnome-control-center-udisks.patch"))))
+ "03np0mhfl9kkdw4cb711pda0cli9zgh2bq2gqn2zwbdi3qnhk9gs"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -6355,7 +6353,11 @@ devices using the GNOME desktop.")
("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
+ ("xsltproc" ,libxslt)
+ ;; For tests
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("python-dbusmock" ,python-dbusmock)
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("accountsservice" ,accountsservice)
("clutter-gtk" ,clutter-gtk)
@@ -6371,6 +6373,7 @@ devices using the GNOME desktop.")
("gnome-session" ,gnome-session)
("gnome-settings-daemon" ,gnome-settings-daemon)
("grilo" ,grilo)
+ ("gsound" ,gsound)
("ibus" ,ibus)
("libcanberra" ,libcanberra)
("libgnomekbd" ,libgnomekbd)