summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cadd4d0655..4d92f58eb5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2121,7 +2121,9 @@ dealing with different structured file formats.")
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs
- `(("pango" ,pango)
+ `(;; XXX: 1.44 causes some test failures, so we stick with 1.42 for
+ ;; this ancient version of librsvg.
+ ("pango" ,pango-1.42)
("libcroco" ,libcroco)
("bzip2" ,bzip2)
("libgsf" ,libgsf)
@@ -3111,7 +3113,7 @@ Hints specification (EWMH).")
`(("bison" ,bison)
("docbook-xml" ,docbook-xml)
("intltool" ,intltool)
- ("itstool" ,itstool/fixed) ;see <https://bugs.gnu.org/37468>
+ ("itstool" ,itstool)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "http://www.gnumeric.org")
@@ -3428,6 +3430,7 @@ and RDP protocols.")
"mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "dconf-meson-0.52.patch"))
(sha256
(base32
"1azz4hb9z76yxn34yrrsiib3iqz5z4vpwn5q7cncp55w365ygg38"))))
@@ -3981,7 +3984,7 @@ more fun.")
("vte" ,vte)
("gnutls" ,gnutls)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("util-linux" ,util-linux)
+ ("util-linux" ,util-linux "lib")
("vala" ,vala)))
(home-page "https://wiki.gnome.org/Apps/Terminal")
(synopsis "Terminal emulator")
@@ -5655,17 +5658,6 @@ lifting is done by packages like yelp-xsl and itstool. This package just
wraps things up in a developer-friendly way.")
(license license:gpl2+)))
-(define-public yelp-tools/fixed
- ;; This variant fixes a python-libxml2 crash when processing UTF-8
- ;; sequences: <https://bugs.gnu.org/37468>. TODO: Remove this in
- ;; the next rebuild cycle.
- (hidden-package
- (package/inherit
- yelp-tools
- (propagated-inputs
- `(("itstool" ,itstool/fixed)
- ,@(alist-delete "itstool" (package-propagated-inputs yelp-tools)))))))
-
(define-public libgee
(package
(name "libgee")
@@ -7464,7 +7456,7 @@ easy, safe, and automatic.")
("openjpeg" ,openjpeg-1)
("libseccomp" ,libseccomp)
("libsoup" ,libsoup)
- ("libuuid" ,util-linux)
+ ("libuuid" ,util-linux "lib")
("network-manager" ,network-manager)))
(synopsis "Metadata database, indexer and search tool")
(home-page "https://wiki.gnome.org/Projects/Tracker")