summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm37
1 files changed, 11 insertions, 26 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 04259e8f89..dffebe92eb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
+;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2110,7 +2111,7 @@ editors, IDEs, etc.")
(package
(inherit vte)
(name "vte-ng")
- (version "0.50.2.a")
+ (version "0.52.2.a")
(native-inputs
`(("gtk-doc" ,gtk-doc)
("gperf" ,gperf)
@@ -2125,14 +2126,13 @@ editors, IDEs, etc.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0sv666ilid916ja6gw2d376nyyy66gvhsds8ans02x4b7gagj5sx"))))
+ "1fd65mk7c87k03vhnb2ixkjvv9nja04mfq813iyjji1b11f2sh7v"))))
(arguments
- `(#:configure-flags '("CXXFLAGS=-Wformat=0")
- #:phases (modify-phases %standard-phases
- (replace 'bootstrap
+ `(#:phases (modify-phases %standard-phases
+ (replace 'bootstrap
(lambda _
(setenv "NOCONFIGURE" "true")
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(synopsis "Enhanced VTE terminal widget")
(description
"VTE is a library (libvte) implementing a terminal emulator widget for
@@ -6477,7 +6477,7 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(define-public faba-icon-theme
(package
(name "faba-icon-theme")
- (version "4.1.2")
+ (version "4.3")
(source
(origin
(method url-fetch)
@@ -6486,23 +6486,8 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hi2dl627ayfnihn3v6x9xzid668m4hp098hb7hrkxvahh4h9by7"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-makefile.am
- (lambda _
- (substitute* '("Makefile.am")
- (("\\$\\(DESTDIR\\)/usr/share")
- "$(datadir)"))
- #t))
- (add-after 'unpack 'disable-configure-during-bootstrap
- (lambda _
- ;; Do not run configure as part of autogen.sh because references
- ;; to /bin are not fixed yet.
- (setenv "NOCONFIGURE" "y")
- #t)))))
+ "18ln06xl60qzvzz61zq9q72hdbfgjsza3flph8i2asyzx3dffz68"))))
+ (build-system meson-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))
@@ -6518,7 +6503,7 @@ Moka")
(package
(inherit faba-icon-theme)
(name "moka-icon-theme")
- (version "5.3.6")
+ (version "5.4.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/moka-project"
@@ -6527,7 +6512,7 @@ Moka")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "04axinv79qnngsxkwqzi5j9lc3hn24rjqps5ai8d42pdnfaf0x37"))))
+ "1nbwdjj268hxv9lfagd9aylily9f0hhallp841v0i3imljp84bmk"))))
(propagated-inputs
;; Moka is based on Faba by using it as a fallback icon set instead of
;; bundling it, so we need to add it as a propagated input.