summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm95
1 files changed, 92 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 319c2e6fd0..2f2124518a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -146,6 +147,7 @@
#:use-module (gnu packages virtualization)
#:use-module (gnu packages vpn)
#:use-module (gnu packages xorg)
+ #:use-module (ice-9 match)
#:use-module (srfi srfi-1))
(define-public brasero
@@ -5815,7 +5817,7 @@ files.")
(define-public baobab
(package
(name "baobab")
- (version "3.26.1")
+ (version "3.28.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5824,11 +5826,15 @@ files.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0zkqxyqyxd6j270jf5hbcrb3yh4k31ddh40v4cjhgngm8mcsnnbs"))))
- (build-system glib-or-gtk-build-system)
+ "0qsx7vx5c3n4yxlxbr11sppw7qwcv9z3g45b5xb9y7wxw5lv42sk"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:glib-or-gtk? #t))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)
+ ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("itstool" ,itstool)
("xmllint" ,libxml2)
("glib" ,glib "bin")
@@ -7192,3 +7198,86 @@ into audio files that a personal computer or digital audio player can play.
It supports ripping to any audio codec supported by a GStreamer plugin, such as
mp3, Ogg Vorbis and FLAC")
(license license:gpl2+)))
+
+(define-public workrave
+ (let ((commit "v1_10_20"))
+ (package
+ (name "workrave")
+ (version (string-map (match-lambda
+ (#\_ #\.)
+ (chr chr))
+ (string-drop commit 1)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcaelers/workrave.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "099a87zkrkmsgfz9isrfm89dh545x52891jh6qxmn19h6wwsi941"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (invoke "sh" "autogen.sh")
+ #t)))))
+ (propagated-inputs `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gtkmm" ,gtkmm)
+ ("glibmm" ,glibmm)
+ ("libx11" ,libx11)
+ ("libxtst" ,libxtst)
+ ("dconf" ,dconf)
+ ("libice" ,libice)))
+ (inputs `(("libsm", libsm)
+ ("python-cheetah" ,python2-cheetah)))
+ (native-inputs `(("glib" ,glib "bin")
+ ("pkg-config" ,pkg-config)
+ ("gettext" ,gnu-gettext)
+ ("autoconf" ,autoconf)
+ ("autoconf-archive" , autoconf-archive)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("intltool" ,intltool)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("gobject-introspection" ,gobject-introspection)
+ ("python2" ,python-2)))
+ (synopsis "Tool to help prevent repetitive strain injury (RSI)")
+ (description "Workrave is a program that assists in the recovery and
+prevention of repetitive strain injury (RSI). The program frequently alerts
+you to take micro-pauses, rest breaks and restricts you to your daily limit")
+ (home-page "http://www.workrave.org")
+ (license license:gpl3+))))
+
+(define-public ghex
+ (package
+ (name "ghex")
+ (version "3.18.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1lq8920ad2chi9ibmyq0x9hg9yk63b0kdbzid03w42cwdzw50x66"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gnome-common" ,gnome-common)
+ ("which" ,which)
+ ("intltool" ,intltool)
+ ("yelp-tools" ,yelp-tools)
+ ("desktop-file-utils" ,desktop-file-utils))) ;for 'desktop-file-validate'
+ (inputs
+ `(("atk" ,atk)
+ ("gtk" ,gtk+)))
+ (synopsis "GNOME hexadecimal editor")
+ (description "The GHex program can view and edit files in two ways:
+hexadecimal or ASCII. It is useful for editing binary files in general.")
+ (home-page "https://wiki.gnome.org/Apps/Ghex")
+ (license license:gpl2)))