summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm45
1 files changed, 43 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e295725c51..ca00bb0ffd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5962,7 +5962,10 @@ devices using the GNOME desktop.")
(arguments
'(#:glib-or-gtk? #t
#:configure-flags
- (list "-Dcheese=false")
+ (list "-Dcheese=false"
+ (string-append "-Dgnome_session_libexecdir="
+ (assoc-ref %build-inputs "gnome-session")
+ "/libexec"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
@@ -5970,7 +5973,8 @@ devices using the GNOME desktop.")
(let ((libc (assoc-ref inputs "libc"))
(tzdata (assoc-ref inputs "tzdata"))
(libgnomekbd (assoc-ref inputs "libgnomekbd"))
- (nm-applet (assoc-ref inputs "network-manager-applet")))
+ (nm-applet (assoc-ref inputs "network-manager-applet"))
+ (gnome-desktop (assoc-ref inputs "gnome-desktop")))
(substitute* "panels/datetime/tz.h"
(("/usr/share/zoneinfo/zone.tab")
(string-append tzdata "/share/zoneinfo/zone.tab")))
@@ -5990,6 +5994,10 @@ devices using the GNOME desktop.")
(substitute* '("panels/user-accounts/run-passwd.c")
(("/usr/bin/passwd")
"/run/setuid-programs/passwd"))
+ (substitute* "panels/info/cc-info-overview-panel.c"
+ (("DATADIR \"/gnome/gnome-version.xml\"")
+ (string-append "\"" gnome-desktop
+ "/share/gnome/gnome-version.xml\"")))
#t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
@@ -6009,6 +6017,7 @@ devices using the GNOME desktop.")
("gnome-desktop" ,gnome-desktop)
("gnome-online-accounts" ,gnome-online-accounts)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("gnome-session" ,gnome-session)
("gnome-settings-daemon" ,gnome-settings-daemon)
("grilo" ,grilo)
("ibus" ,ibus)
@@ -8306,3 +8315,35 @@ advanced image management tool")
(description "The aim of the handy library is to help with developing user
intefaces for mobile devices using GTK+.")
(license license:lgpl2.1+)))
+
+(define-public libgit2-glib
+ (package
+ (name "libgit2-glib")
+ (version "0.28.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0a0g7aw66rfgnqr4z7fgbk5zzcjq66m4rp8v4val3a212941h0g7"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ;; For glib-mkenums
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("libssh2" ,libssh2)
+ ("pkg-config" ,pkg-config)
+ ("python-pygobject" ,python-pygobject)
+ ("python-wrapper" ,python-wrapper)
+ ("vala" ,vala)))
+ (inputs
+ `(("glib" ,glib)
+ ("libgit2" ,libgit2)))
+ (synopsis "GLib wrapper around the libgit2 Git access library")
+ (description "libgit2-glib is a GLib wrapper library around the libgit2 Git
+access library. It only implements the core plumbing functions, not really the
+higher level porcelain stuff.")
+ (home-page "https://wiki.gnome.org/Projects/Libgit2-glib")
+ (license license:gpl2+)))