summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 17 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 311083395a..83344de2a6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -122,6 +122,7 @@
#:use-module (gnu packages ssh)
#:use-module (gnu packages xml)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages compression)
#:use-module (gnu packages spice)
#:use-module (gnu packages tex)
@@ -938,14 +939,14 @@ guidelines.")
(define-public shared-mime-info
(package
(name "shared-mime-info")
- (version "1.8")
+ (version "1.9")
(source (origin
(method url-fetch)
(uri (string-append "https://freedesktop.org/~hadess/"
"shared-mime-info-" version ".tar.xz"))
(sha256
(base32
- "1sc96lv9dp1lkvs8dh3ngm3hbjb274d363dl9avhb61il3qmxx9a"))))
+ "10ywzhzg8v1xmb9sz5xbqaci90id38knswigynyl33i29vn360aw"))))
(build-system gnu-build-system)
(arguments
;; The build system appears not to be parallel-safe.
@@ -2034,7 +2035,7 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.36.3")
+ (version "0.40.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -2042,7 +2043,7 @@ passwords in the GNOME keyring.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0706izk9prxqclm7gv4f63diwnlc1llvfl5sc9ghqbgn076lx2mc"))))
+ "1v0ak68lrnbb5lyd48j6sxa35vfrii86zmhxdhkdb85k1bv65rmy"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -2050,20 +2051,25 @@ passwords in the GNOME keyring.")
(add-before 'check 'pre-check
(lambda _
(setenv "CC" "gcc")
+ (substitute* "valadoc/tests/testrunner.sh"
+ (("export PKG_CONFIG_PATH=" m)
+ (string-append m "$PKG_CONFIG_PATH:")))
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
- #t)))
- ;; Build the Vala API generator
- #:configure-flags '("--enable-vapigen")))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("flex" ,flex)
("bison" ,bison)
("xsltproc" ,libxslt)
+ ("grep" ,grep)
+ ("sed" ,sed)
("dbus" ,dbus) ; for dbus tests
("gobject-introspection" ,gobject-introspection))) ; for gir tests
+ (inputs
+ `(("graphviz" ,graphviz)))
(propagated-inputs
- `(("glib" ,glib))) ; required by libvala-0.26.pc
+ `(("glib" ,glib))) ; required by libvala-0.40.pc
(home-page "https://live.gnome.org/Vala/")
(synopsis "Compiler for the GObject type system")
(description
@@ -5859,7 +5865,7 @@ is complete it provides a graphical representation of each selected folder.")
(define-public gnome-backgrounds
(package
(name "gnome-backgrounds")
- (version "3.26.2")
+ (version "3.28.0")
(source
(origin
(method url-fetch)
@@ -5868,8 +5874,8 @@ is complete it provides a graphical representation of each selected folder.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0kzrh5h0cfby3rhsy31d1w1c0rr3wcc845kv6zibqw1x8v9si2rs"))))
- (build-system glib-or-gtk-build-system)
+ "1qgim0yhzjgcq172y4vp5hqz4rh1ak38a7pgi6s7dq0wklyrcnxj"))))
+ (build-system meson-build-system)
(native-inputs
`(("intltool" ,intltool)))
(home-page "https://git.gnome.org/browse/gnome-backgrounds")