summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 6 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6fcd3ceb9c..311083395a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4002,39 +4002,26 @@ DAV, and others.")
(define-public gusb
(package
(name "gusb")
- (version "0.2.9")
+ (version "0.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/hughsie/libgusb/archive/"
- "gusb_"
- (string-join (string-split version #\.)
- "_")
- ".tar.gz"))
+ version ".tar.gz"))
(sha256
(base32
- "1500mgpidmnjfkcz1fzqkbqv547iy1cvr8bwf3k9vqgqcjx3844n"))))
- (build-system gnu-build-system)
+ "1wa9787ww7s1kl9jml6kiyrjgimlgagq4jmgdj7xcpsx83w10qxk"))))
+ (build-system meson-build-system)
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
- ("gobject-introspection" ,gobject-introspection)
+ `(("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("vala" ,vala)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
("gtk-doc" ,gtk-doc)))
(propagated-inputs
;; Both of these are required by gusb.pc.
`(("glib" ,glib)
("libusb" ,libusb)))
(arguments
- `(#:tests? #f ; libusb fails to initialize. Wonder what that is.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (and (zero? (system* "gtkdocize"))
- (zero? (system* "autoreconf" "-vif"))))))))
+ `(#:tests? #f)) ;libusb fails to initialize. Wonder what that is.
(home-page "https://github.com/hughsie/libgusb")
(synopsis "GLib binding for libusb1")
(description