summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm64
1 files changed, 59 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f7bbac214..601248b7f5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2019 Jonathan Frederickson <jonathan@terracrypt.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8152,15 +8153,18 @@ advanced image management tool")
(inputs
`(("cairo" ,cairo)
("gobject-introspection" ,gobject-introspection)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("python2-pycairo" ,python2-pycairo)
("python2-pygobject" ,python2-pygobject)
("python2-psutil" ,python2-psutil)
("vte" ,vte)))
- (propagated-inputs
- ;; Terminator refuses to start when these are not present.
- `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(arguments
- `(#:python ,python-2 ;Python 3 not supported
+ `(#:python ,python-2 ; Python 3 isn't supported
+ #:imported-modules ((guix build glib-or-gtk-build-system)
+ ,@%python-build-system-modules)
+ #:modules ((guix build python-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build utils))
#:phases
(modify-phases %standard-phases
(add-after
@@ -8171,10 +8175,60 @@ advanced image management tool")
(wrap-program prog
`("PYTHONPATH" = (,(getenv "PYTHONPATH")))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
- #t))))))
+ #t)))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(home-page "https://gnometerminator.blogspot.com/")
(synopsis "Store and run multiple GNOME terminals in one window")
(description
"Terminator allows you to run multiple GNOME terminals in a grid and
+tabs, and it supports drag and drop re-ordering of terminals.")
(license license:gpl2)))
+
+(define-public libhandy
+ (package
+ (name "libhandy")
+ (version "0.0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/libhandy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1702hbdqhfpgw0c4vj2ag08vgl83byiryrbngbq11b9azmj3jhzs"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ '("-Dglade_catalog=disabled"
+ "-Dgtk_doc=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ ;; This test fails for unknown reasons
+ (substitute* "tests/meson.build"
+ (("'test-dialog',") ""))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (inputs
+ `(("gtk+" ,gtk+)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection) ; for g-ir-scanner
+ ("vala" ,vala)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("gettext" ,gettext-minimal)
+ ("xorg-server" ,xorg-server)))
+ (home-page "https://source.puri.sm/Librem5/libhandy")
+ (synopsis "Library full of GTK+ widgets for mobile phones")
+ (description "The aim of the handy library is to help with developing user
+intefaces for mobile devices using GTK+.")
+ (license license:lgpl2.1+)))