summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm50
1 files changed, 44 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5c2cf0197e..0fd1d5bb29 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,6 +58,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages docbook)
#:use-module (gnu packages enchant)
+ #:use-module (gnu packages game-development)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
@@ -737,8 +739,8 @@ the API.")
version "/gtkglext-" version ".tar.gz"))
(sha256
(base32 "1ya4d2j2aacr9ii5zj4ac95fjpdvlm2rg79mgnk7yvl1dcy3y1z5"))
- (patches (list
- (search-patch "gtkglext-disable-disable-deprecated.patch")))))
+ (patches (search-patches
+ "gtkglext-disable-disable-deprecated.patch"))))
(build-system gnu-build-system)
(inputs `(("gtk+" ,gtk+-2)
("mesa" ,mesa)
@@ -1008,7 +1010,8 @@ featuring mature C, C++ and Python bindings.")
"/" name "-" version ".tar.bz2"))
(sha256
(base32 "0swp4kk6x7hy1rvd1f9jba31lvfc6qvafkvbpg9h0r34fzrd8q4i"))
- (patches (list (search-patch "libbonobo-activation-test-race.patch")))))
+ (patches (search-patches
+ "libbonobo-activation-test-race.patch"))))
(build-system gnu-build-system)
(arguments
;; The programmer kindly gives us a hook to turn off deprecation warnings ...
@@ -1974,7 +1977,7 @@ library.")
(base32
"1cchmi08jpjypgmm9i7xzh5qfg2q5k61kry9ns8mhw3z44a440ym"))
(patches
- (list (search-patch "glib-networking-ssl-cert-file.patch")))))
+ (search-patches "glib-networking-ssl-cert-file.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2207,6 +2210,41 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
floating in an ocean using only your brain and a little bit of luck.")
(license license:gpl2+)))
+(define-public gnome-sudoku
+ (package
+ (name "gnome-sudoku")
+ (version "3.18.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1b60z22fjrjzsz0kfhv0kfhvigzn54wvh9s31zrlp7sx2h2dxvsf"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("xmllint" ,libxml2)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("libgee" ,libgee)
+ ("librsvg" ,librsvg)
+ ("qqwing" ,qqwing)))
+ (home-page "https://wiki.gnome.org/Apps/Sudoku")
+ (synopsis "Japanese logic game")
+ (description
+ "Sudoku is a Japanese logic game that exploded in popularity in 2005.
+GNOME Sudoku is meant to have an interface as simple and unobstrusive as
+possible while still providing features that make playing difficult Sudoku
+more fun.")
+ (license license:gpl2+)))
+
(define-public gnome-terminal
(package
(name "gnome-terminal")
@@ -2334,7 +2372,7 @@ output devices.")
(sha256
(base32
"0inlqx0zar498fhi9hh92p2g4kp8qy3zdl4z3vw6bjwp9w6xx454"))
- (patches (list (search-patch "geoclue-config.patch")))))
+ (patches (search-patches "geoclue-config.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
'(;; The tests want to run the system bus.
@@ -2413,7 +2451,7 @@ faster results and to avoid unnecessary server load.")
(sha256
(base32
"0f6x9mi1jzgqdpycaikyhjljnw3aacsl3gxndyg0dfqkq6y9jwb9"))
- (patches (list (search-patch "upower-builddir.patch")))))
+ (patches (search-patches "upower-builddir.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
'( ;; The tests want to contact the system bus, which can't be done in the