summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm143
1 files changed, 50 insertions, 93 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a08cd00d72..67f0e47de1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -941,13 +941,6 @@ useful as a tutorial and users' guide for new or less experienced users.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'dont-configure-during-bootstrap
- (lambda _
- (setenv "NOCONFIGURE" "true")
- #t)))))
(home-page "https://wiki.gnome.org/Apps/Dia")
(synopsis "Diagram creation for GNOME")
(description "Dia can be used to draw different types of diagrams, and
@@ -1346,7 +1339,7 @@ the font would look under various sizes.")
(define-public gcr
(package
(name "gcr")
- (version "3.28.1")
+ (version "3.34.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1354,20 +1347,7 @@ the font would look under various sizes.")
name "-" version ".tar.xz"))
(sha256
(base32
- "12qn7mcmxb45lz1gq3s3b34rimiyrrshkrpvxdw1fc0w26i4l84m"))
- (patches
- (list
- ;; This patch solves an ordering issue that showed up when
- ;; running the test suite against newer Glib 2.60. See
- ;; <https://gitlab.gnome.org/GNOME/gcr/merge_requests/9>.
- (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.gnome.org/GNOME/gcr/commit/"
- "45d637578d7643ff96c0183ac267497a0b4c6344.diff"))
- (file-name "gcr-hashtable-ordering.patch")
- (sha256
- (base32
- "1vsqiys8fsm1f1vvds783wwf7zwi5v282rhsai8jrsm6x7h79gbi")))))))
+ "0925snsixzkwh49xiayqmj6fcrmklqk8kyy0jkv7m64h9abm1pr9"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1376,9 +1356,9 @@ the font would look under various sizes.")
;; build environment.
(add-after 'unpack 'disable-failing-tests
(lambda _
- (substitute* "gcr/test-system-prompt.c"
- (("g_test_add") "//")
- (("return.*") "return 0;"))
+ (substitute* "Makefile.in"
+ (("[[:blank:]]+test-system-prompt\\$\\(EXEEXT\\)")
+ ""))
#t))
(add-before 'check 'pre-check
(lambda _
@@ -1390,11 +1370,11 @@ the font would look under various sizes.")
("gnupg" ,gnupg) ;called as a child process during tests
("libgcrypt" ,libgcrypt)))
(native-inputs
- `(("python" ,python-2) ;for tests
+ `(("python" ,python-wrapper) ;for tests
("pkg-config" ,pkg-config)
+ ("gettext" ,gettext-minimal)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("intltool" ,intltool)
("libxml2" ,libxml2)
("vala" ,vala)
("xsltproc" ,libxslt)))
@@ -1739,14 +1719,16 @@ guidelines.")
(define-public shared-mime-info
(package
(name "shared-mime-info")
- (version "1.10")
+ (version "1.15")
(source (origin
(method url-fetch)
- (uri (string-append "https://freedesktop.org/~hadess/"
- "shared-mime-info-" version ".tar.xz"))
+ (uri (string-append
+ "https://gitlab.freedesktop.org/xdg/shared-mime-info/uploads/"
+ "b27eb88e4155d8fccb8bb3cd12025d5b/shared-mime-info-" version
+ ".tar.xz"))
(sha256
(base32
- "1gxyvwym3xgpmp262gfn8jg5sla6k5hy6m6dmy6grgiq90xsh9f6"))))
+ "146vynj78wcwdq0ms52jzm1r4m6dzi1rhyh3h4xyb6bw8ckv10pl"))))
(build-system gnu-build-system)
(arguments
;; The build system appears not to be parallel-safe.
@@ -1755,7 +1737,8 @@ guidelines.")
`(("glib" ,glib)
("libxml2" ,libxml2)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)
("pkg-config" ,pkg-config)))
(home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
(synopsis "Database of common MIME types")
@@ -2104,9 +2087,8 @@ dealing with different structured file formats.")
(define-public librsvg
(package
- (replacement librsvg/fixed)
(name "librsvg")
- (version "2.40.20")
+ (version "2.40.21")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -2114,7 +2096,7 @@ dealing with different structured file formats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ay9himvw1l1swcf3h1312d2iqzfl65kpbfgiyfykgvq7cydvx6g"))))
+ "1fljkag2gr7c4k5mn798lgf9903xslz8h51bgvl89nnay42qjqpp"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2152,7 +2134,9 @@ dealing with different structured file formats.")
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs
- `(("pango" ,pango)
+ `(;; XXX: 1.44 causes some test failures, so we stick with 1.42 for
+ ;; this ancient version of librsvg.
+ ("pango" ,pango-1.42)
("libcroco" ,libcroco)
("bzip2" ,bzip2)
("libgsf" ,libgsf)
@@ -2169,20 +2153,6 @@ dealing with different structured file formats.")
library.")
(license license:lgpl2.0+)))
-(define librsvg/fixed
- (package
- (inherit librsvg)
- (name "librsvg")
- (version "2.40.21")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1fljkag2gr7c4k5mn798lgf9903xslz8h51bgvl89nnay42qjqpp"))))))
-
(define* (computed-origin-method gexp-promise hash-algo hash
#:optional (name "source")
#:key (system (%current-system))
@@ -2524,7 +2494,9 @@ functionality was designed to be as reusable and portable as possible.")
"0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
+ `(;; The "timeout-server" test hangs when run in parallel.
+ #:parallel-tests? #f
+ #:configure-flags
'(;; We don't need static libraries, plus they don't build reproducibly
;; (non-deterministic ordering of .o files in the archive.)
"--disable-static"
@@ -2857,7 +2829,7 @@ creating interactive structured graphics.")
("libgnome" ,libgnome)
("libgnomecanvas" ,libgnomecanvas)
("libgnome-keyring" ,libgnome-keyring)))
- (inputs `(("libjpeg" ,libjpeg)
+ (inputs `(("libjpeg" ,libjpeg-turbo)
("popt" ,popt)
("libbonobo" ,libbonobo)
("libxml2" ,libxml2)
@@ -3169,7 +3141,7 @@ Hints specification (EWMH).")
`(("bison" ,bison)
("docbook-xml" ,docbook-xml)
("intltool" ,intltool)
- ("itstool" ,itstool/fixed) ;see <https://bugs.gnu.org/37468>
+ ("itstool" ,itstool)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "http://www.gnumeric.org")
@@ -3274,7 +3246,7 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.44.5")
+ (version "0.46.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3282,7 +3254,7 @@ passwords in the GNOME keyring.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0zy2kfcvhikczfzhk5l7pkw6mvn3d6vw8cv7g08iah85p22q33xv"))))
+ "07fv895sp9wq74b20qig7hic0r4ynrr5pfaqba02r44xb794fy0s"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -3486,6 +3458,7 @@ and RDP protocols.")
"mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
+ (patches (search-patches "dconf-meson-0.52.patch"))
(sha256
(base32
"1azz4hb9z76yxn34yrrsiib3iqz5z4vpwn5q7cncp55w365ygg38"))))
@@ -3564,13 +3537,7 @@ and objects.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'no-configure
- (lambda* _
- (setenv "NOCONFIGURE" "1")
- #t)))
- #:configure-flags
+ '(#:configure-flags
(list (string-append "--with-xkb-base="
(assoc-ref %build-inputs "xkeyboard-config")
"/share/X11/xkb")
@@ -4039,7 +4006,7 @@ more fun.")
("vte" ,vte)
("gnutls" ,gnutls)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("util-linux" ,util-linux)
+ ("util-linux" ,util-linux "lib")
("vala" ,vala)))
(home-page "https://wiki.gnome.org/Apps/Terminal")
(synopsis "Terminal emulator")
@@ -5194,7 +5161,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
("lcms" ,lcms)
("libexif" ,libexif)
("libpeas" ,libpeas)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("librsvg" ,librsvg)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)))
@@ -5618,7 +5585,7 @@ of running programs and invoke methods on those interfaces.")
(define-public yelp-xsl
(package
(name "yelp-xsl")
- (version "3.32.1")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5626,10 +5593,10 @@ of running programs and invoke methods on those interfaces.")
name "-" version ".tar.xz"))
(sha256
(base32
- "013z2ixx9kfrs6hq79qpil093xfbc12y1p0mvsh6lpala30iphya"))))
+ "1bdpgkzawhqmw52l6zx8czzg1ndfgcf1p44m2bxjdpqkc4afcgqc"))))
(build-system gnu-build-system)
(native-inputs
- `(("intltool" ,intltool)
+ `(("gettext-minimal" ,gettext-minimal)
("itstool" ,itstool)
("xmllint" ,libxml2)))
(home-page "https://wiki.gnome.org/Apps/Yelp")
@@ -5676,7 +5643,7 @@ freedesktop.org help system specification.")
(define-public yelp-tools
(package
(name "yelp-tools")
- (version "3.28.0")
+ (version "3.32.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -5684,7 +5651,7 @@ freedesktop.org help system specification.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1b61dmlb1sd50fgq6zgnkcpx2s1py33q0x9cx67fzpsr4gmgxnw2"))))
+ "1yg8f5g5wadhmy4yfd9yjhvd8vll4gq4l86ibp0b42qbxnsmcf0q"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -5704,17 +5671,6 @@ lifting is done by packages like yelp-xsl and itstool. This package just
wraps things up in a developer-friendly way.")
(license license:gpl2+)))
-(define-public yelp-tools/fixed
- ;; This variant fixes a python-libxml2 crash when processing UTF-8
- ;; sequences: <https://bugs.gnu.org/37468>. TODO: Remove this in
- ;; the next rebuild cycle.
- (hidden-package
- (package/inherit
- yelp-tools
- (propagated-inputs
- `(("itstool" ,itstool/fixed)
- ,@(alist-delete "itstool" (package-propagated-inputs yelp-tools)))))))
-
(define-public libgee
(package
(name "libgee")
@@ -6546,6 +6502,10 @@ users.")
(lambda _
;; For the missing /etc/machine-id.
(setenv "DBUS_FATAL_WARNINGS" "0")
+
+ ;; XXX: Regenerate some of the tests that are dependent on Python version.
+ ;; Try removing this variable for newer versions of NetworkManager.
+ (setenv "NM_TEST_REGENERATE" "1")
#t))
(replace 'install
(lambda _
@@ -7568,7 +7528,7 @@ endpoint and it understands SPARQL. ")
("libgsf" ,libgsf)
("libgxps" ,libgxps)
("libiptcdata" ,libiptcdata)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libosinfo" ,libosinfo)
("libpng" ,libpng)
("libseccomp" ,libseccomp)
@@ -8006,7 +7966,7 @@ documents and diagrams, playing media, scanning, and much more.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (replace 'bootstrap
+ (add-before 'bootstrap 'build-without-Werror
(lambda _
;; The build system cleverly detects that we're not building from
;; a release tarball and turns on -Werror for GCC.
@@ -8014,11 +7974,7 @@ documents and diagrams, playing media, scanning, and much more.")
;; causes the build to fail unnecessarily, so we remove the flag.
(substitute* '("configure.ac")
(("-Werror") ""))
- ;; The autogen.sh script in gnome-common will run ./configure
- ;; by default, which is problematic because source shebangs
- ;; have not yet been patched.
- (setenv "NOCONFIGURE" "t")
- (zero? (system* "sh" "autogen.sh")))))))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -8622,7 +8578,7 @@ handling the startup notification side.")
(define-public gnome-calculator
(package
(name "gnome-calculator")
- (version "3.32.2")
+ (version "3.34.1")
(source
(origin
(method url-fetch)
@@ -8631,19 +8587,20 @@ handling the startup notification side.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0fgpn3sc226s9fpzhik5rkkrf669037gc659ga2kn9jsyckj6p41"))))
+ "0lbh87255zzggqzai6543qg920y52bl4vs5m5h5087ghzg14hlsd"))))
(build-system meson-build-system)
(arguments '(#:glib-or-gtk? #t))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
- ("intltool" ,intltool)
("itstool" ,itstool)
("vala" ,vala)
("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)
("gtksourceview" ,gtksourceview)
+ ("libgee" ,libgee)
("libsoup" ,libsoup)
("libxml2" ,libxml2)
("mpc" ,mpc)
@@ -9086,7 +9043,7 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
("python-gst" ,python-gst)
("python-pil" ,python-pillow)
("python-pycairo" ,python-pycairo)
- ("python-pygobject" ,python-pygobject-3.34)
+ ("python-pygobject" ,python-pygobject)
("python-pylast" ,python-pylast)
("totem-pl-parser" ,totem-pl-parser)
("webkitgtk" ,webkitgtk)))
@@ -9528,7 +9485,7 @@ functionality.")
("clutter" ,clutter)
("clutter-gst" ,clutter-gst)
("clutter-gtk" ,clutter-gtk)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("libtiff" ,libtiff)
("libraw" ,libraw)))
(home-page "https://wiki.gnome.org/Apps/Gthumb")