aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm25
1 files changed, 9 insertions, 16 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8db53f109a..96dcbda72e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -714,7 +714,7 @@ update-desktop-database: updates the database containing a cache of MIME types
(define-public adwaita-icon-theme
(package (inherit gnome-icon-theme)
(name "adwaita-icon-theme")
- (version "3.22.0")
+ (version "3.24.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -722,7 +722,7 @@ update-desktop-database: updates the database containing a cache of MIME types
name "-" version ".tar.xz"))
(sha256
(base32
- "1dyw8mm72wfpkn83vdqr0ifv5yhy565jhxrcjsd83nc7c3igd2y1"))))
+ "0ai73gs44yyw276xag6db0rlpvncy23qplp4girm80ilpprrzxyc"))))
(native-inputs
`(("gtk-encode-symbolic-svg" ,gtk+ "bin")))))
@@ -1848,7 +1848,7 @@ libraries written in C.")
(define-public vte
(package
(name "vte")
- (version "0.46.1")
+ (version "0.48.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1856,22 +1856,15 @@ libraries written in C.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1ipmnfazvhzjp5pjw90mmxbkizivnh7gnlqqml94lw2rqa5wy048"))))
+ "14060d5rmjjmxaknrabhnsjwxni5wa3crg61mqxv8f7yxl0v6y62"))))
(build-system gnu-build-system)
- (arguments
- ;; XXX: fails to compile tests with the default flags.
- ;; vteconv.cc:774:40:
- ;; error: missing sentinel in function call [-Werror=format=]
- ;; g_test_init (&argc, &argv, NULL);
- ;;
- ;; cc1plus: some warnings being treated as errors
- '(#:configure-flags '("CXXFLAGS=-Wformat=0")))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)
("vala" ,vala)
("gobject-introspection" ,gobject-introspection)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
+ ("gperf" ,gperf)
("xmllint" ,libxml2)))
(propagated-inputs
`(("gtk+" ,gtk+) ;required by vte-2.91.pc
@@ -2440,7 +2433,7 @@ more fun.")
(define-public gnome-terminal
(package
(name "gnome-terminal")
- (version "3.22.1")
+ (version "3.24.1")
(source
(origin
(method url-fetch)
@@ -2449,7 +2442,7 @@ more fun.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1m5h3ck7wcvq1kfap05jwhnbpp3kmikc2qy822gnsbdjdqrm41xh"))))
+ "1q303bljcr06w3ra737kq1hpjda45wk16kmrixxwldf3zkk2dgx7"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:configure-flags
@@ -5243,7 +5236,7 @@ files.")
(define-public baobab
(package
(name "baobab")
- (version "3.22.1")
+ (version "3.24.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5252,7 +5245,7 @@ files.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1zwpzj6hbvcyw1ymqzn3zw8w4h29ad7411crbkbh71c8jwbwpssv"))))
+ "0gzwzn8p0agidjq3wnkxcsny6jhqph3yqscqjqd7blgkz5nyk02r"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("intltool" ,intltool)