summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a64407a36f..30a22d7d59 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -499,7 +499,7 @@ has an ease of use unmatched by other C++ callback libraries.")
(define glibmm
(package
(name "glibmm")
- (version "2.50.1")
+ (version "2.54.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/glibmm/"
@@ -507,10 +507,13 @@ has an ease of use unmatched by other C++ callback libraries.")
"/glibmm-" version ".tar.xz"))
(sha256
(base32
- "1926b3adx903hzvdp8glblsgjyadzqnwgkj8hg605d4wv98m1n0z"))))
+ "0jkapw18icz59cmlmsl00nwwz0wh291kb4hc9z9hxmq45drqrhkw"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(;; XXX: Some tests uses C++14 features. Remove this when the default
+ ;; compiler is >= GCC6.
+ #:configure-flags '("CXXFLAGS=-std=gnu++14")
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'pre-build
(lambda _
@@ -532,7 +535,7 @@ has an ease of use unmatched by other C++ callback libraries.")
(propagated-inputs
`(("libsigc++" ,libsigc++)
("glib" ,glib)))
- (home-page "http://gtkmm.org/")
+ (home-page "https://gtkmm.org/")
(synopsis "C++ interface to the GLib library")
(description
"Glibmm provides a C++ programming interface to the part of GLib that are
@@ -544,7 +547,7 @@ useful for C++.")
(name "python2-pygobject")
;; This was the last version to declare the 2.0 platform number, i.e. its
;; pkg-config files were named pygobject-2.0.pc
- (version "2.28.6")
+ (version "2.28.7")
(source
(origin
(method url-fetch)
@@ -553,7 +556,7 @@ useful for C++.")
"/pygobject-" version ".tar.xz"))
(sha256
(base32
- "1f5dfxjnil2glfwxnqr14d2cjfbkghsbsn8n04js2c2icr7iv2pv"))
+ "0nkam61rsn7y3wik3vw46wk5q2cjfh2iph57hl9m39rc8jijb7dv"))
(patches (search-patches
"python2-pygobject-2-gi-info-type-error-domain.patch"))))
(build-system gnu-build-system)