summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 45f4631f9f..6de9cce0b7 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -157,17 +157,18 @@ shared NFS home directories.")
`(("coreutils" ,coreutils)
("util-linux" ,util-linux) ; for libmount
("libffi" ,libffi)
- ("zlib" ,zlib)
- ("tzdata" ,tzdata))) ; for tests/gdatetime.c
+ ("zlib" ,zlib)))
(native-inputs
`(("gettext" ,gettext-minimal)
("dbus" ,dbus) ; for GDBus tests
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
("perl" ,perl) ; needed by GIO tests
- ("bash" ,bash)))
+ ("bash" ,bash)
+ ("tzdata" ,tzdata-2017a))) ; for tests/gdatetime.c
(arguments
- '(#:phases
+ `(#:disallowed-references (,tzdata-2017a)
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)