summaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 30a22d7d59..34968f9d91 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -78,7 +78,7 @@
(define dbus
(package
(name "dbus")
- (version "1.12.2")
+ (version "1.12.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -86,7 +86,7 @@
version ".tar.gz"))
(sha256
(base32
- "121xm3cy48vbv6nv522lfkk4zyiqc1g6v4lb3344gc3h2w4vaar7"))
+ "05picaq8j60wlwyi84qvw5liw3nd0cws9va3krnc3pms0wm906v2"))
(patches (search-patches "dbus-helper-search-path.patch"))))
(build-system gnu-build-system)
(arguments
@@ -148,7 +148,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.54.2")
+ (version "2.54.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -156,7 +156,7 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0v4ffl172kbqgxrhgxyafhpw36bq3iklb2zjqyl6jcfkmb2yb2dv"))
+ "1a60p9m493mvm42rskg8ifr0jmsbr8arzyqx73jshgfwhmkdqgwn"))
(patches (search-patches "glib-respect-datadir.patch"
"glib-tests-timer.patch"))))
(build-system gnu-build-system)
@@ -369,13 +369,14 @@ bindings to call into the C library.")
("perl-xml-parser" ,perl-xml-parser)
("perl" ,perl)))
(arguments
- `(#:phases (alist-cons-after
- 'unpack 'patch-file-references
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((file (assoc-ref inputs "file")))
- (substitute* "intltool-update.in"
- (("`file") (string-append "`" file "/bin/file")))))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((file (assoc-ref inputs "file")))
+ (substitute* "intltool-update.in"
+ (("`file") (string-append "`" file "/bin/file")))
+ #t))))))
(home-page "https://launchpad.net/intltool/+download")
(synopsis "Tools to centralise translations of different file formats")
(description