summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 96e7fc7165..4d3828ebc2 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -399,6 +399,21 @@ device drivers allows Mesa to be used in many different environments ranging
from software emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
+(define-public mesa-opencl
+ (package
+ (inherit mesa)
+ (name "mesa-opencl")
+ (arguments
+ (substitute-keyword-arguments (package-arguments mesa)
+ ((#:configure-flags flags)
+ `(cons "-Dgallium-opencl=standalone" ,flags))))
+ (inputs
+ `(("libclc" ,libclc)
+ ,@(package-inputs mesa)))
+ (native-inputs
+ `(("clang" ,clang)
+ ,@(package-native-inputs mesa)))))
+
(define-public mesa-headers
(package
(inherit mesa)