summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d2be6a5127..96e7fc7165 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -328,6 +328,15 @@ also known as DXTn or DXTC) for Mesa.")
(substitute* "src/intel/genxml/gen_pack_header.py"
(("/usr/bin/env python2") (which "python")))
#t))
+ ,@(if (string-prefix? "i686" (%current-system))
+ ;; Disable new test from Mesa 19 that fails on i686. Upstream
+ ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
+ `((add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "src/gallium/tests/unit/meson.build"
+ (("'u_format_test',") ""))
+ #t)))
+ '())
(add-before
'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)