summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 0c212ca928..7c217d903b 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -39,6 +39,7 @@
(define-public lcms
(package
(name "lcms")
+ (replacement lcms/fixed)
(version "2.6")
(source (origin
(method url-fetch)
@@ -58,6 +59,14 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(license license:x11)
(home-page "http://www.littlecms.com/")))
+(define lcms/fixed
+ (package
+ (inherit lcms)
+ (source
+ (origin
+ (inherit (package-source lcms))
+ (patches (search-patches "lcms-fix-out-of-bounds-read.patch"))))))
+
(define-public libpaper
(package
(name "libpaper")