summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm20
1 files changed, 6 insertions, 14 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 384f274aee..d78e2e0f11 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -140,7 +140,7 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.32.2.1")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -148,7 +148,7 @@ topology functions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1m191iq1gjaqz79ci3dkbmwrkxp7pzknngimlf5bqib5x8yairlb"))))
+ "00xslcnhhwslqglgfv2im7vq3awa49y2jxzr8wsby7f713k28vf5"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -1444,7 +1444,7 @@ using the dataset of topographical information collected by
("qtwebengine" ,qtwebengine)
("quazip" ,quazip)
("routino" ,routino)
- ("sqlite" ,sqlite-with-column-metadata) ; See wrap phase
+ ("sqlite" ,sqlite) ; See wrap phase
("zlib" ,zlib)))
(arguments
`(#:tests? #f
@@ -1465,23 +1465,15 @@ using the dataset of topographical information collected by
(invoke "patch" "-p1" "-i" "FindQuaZip5.patch")
#t))
(add-after 'install 'wrap
- ;; The program fails to run with the error:
- ;; undefined symbol: sqlite3_column_table_name16
- ;; Forcing the program to use sqlite-with-column-metadata instead
- ;; of sqlite using LD_LIBRARY_PATH solves the problem.
- ;;
- ;; The program also fails to find the QtWebEngineProcess program,
+ ;; The program fails to find the QtWebEngineProcess program,
;; so we set QTWEBENGINEPROCESS_PATH to help it.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin"))
(qtwebengineprocess (string-append
(assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess"))
- (sqlite-lib (string-append (assoc-ref inputs "sqlite")
- "/lib")))
+ "/lib/qt5/libexec/QtWebEngineProcess")))
(for-each (lambda (program)
(wrap-program program
- `("LD_LIBRARY_PATH" ":" prefix (,sqlite-lib))
`("QTWEBENGINEPROCESS_PATH" =
(,qtwebengineprocess))))
(find-files bin ".*")))
@@ -1993,7 +1985,7 @@ growing set of geoscientific methods.")
("qtwebkit" ,qtwebkit)
("qwt" ,qwt)
("saga" ,saga)
- ("sqlite" ,sqlite-with-column-metadata)))
+ ("sqlite" ,sqlite)))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)