summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 1346ebeb5f..05d177c3b1 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -561,6 +561,14 @@ development.")
("sqlite" ,sqlite)
("wxwidgets" ,wxwidgets-2)
("zlib" ,zlib)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-gui
+ (lambda _
+ ;; Fix for the GUI not showing up.
+ (substitute* "Main.cpp"
+ (("Hide\\(\\);") ""))
+ #t)))))
(synopsis "Graphical user interface for SpatiaLite")
(description "Spatialite-gui provides a visual interface for viewing and
maintaining a spatialite database. You can easily see the structure of the