summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 4d6b1a3c89..3313ee68f2 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
@@ -40,16 +40,21 @@
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/libgd/libgd/releases/download/gd-"
version "/libgd-" version ".tar.xz"))
+ (patches (search-patches "gd-fix-test-on-i686.patch"
+ "gd-CVE-2016-5766.patch"
+ "gd-CVE-2016-6128.patch"
+ "gd-CVE-2016-6132.patch"
+ "gd-CVE-2016-6214.patch"))
(sha256
(base32
- "0xmrqka1ggqgml84xbmkw1y0r0lg7qn657v5b1my8pry92p651vh"))))
+ "1311g5mva2xlzqv3rjqjc4jjkn5lzls4skvr395h633zw1n7b7s8"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))