summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 2d3ee4200d..c6a2e0117d 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -42,7 +42,7 @@
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.5")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -50,19 +50,15 @@
version "/libgd-" version ".tar.xz"))
(sha256
(base32
- "0lfy5f241sbv8s3splm2zqiaxv7lxrcshh875xryryk7yk5jqc4c"))
-
- (patches (search-patches "gd-CVE-2018-5711.patch"
- "gd-CVE-2018-1000222.patch"
- "gd-CVE-2019-6977.patch"
- "gd-CVE-2019-6978.patch"
- "gd-fix-tests-on-i686.patch"
- "gd-freetype-test-failure.patch"))))
+ "0n5czhxzinvjvmhkf5l9fwjdx5ip69k5k7pj6zwb6zs1k9dibngc"))
+ (patches (search-patches "gd-fix-tests-on-i686.patch"
+ "gd-brect-bounds.patch"))))
(build-system gnu-build-system)
(arguments
;; As recommended by github.com/libgd/libgd/issues/278 to fix rounding
;; issues on aarch64 and other architectures.
`(#:make-flags '("CFLAGS=-ffp-contract=off")
+ #:configure-flags '("--disable-static")
#:phases
(modify-phases %standard-phases
;; This test is known to fail on i686-linux:
@@ -77,12 +73,11 @@
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("freetype" ,freetype)
+ `(("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("zlib" ,zlib)))
- (propagated-inputs
- `(("fontconfig" ,fontconfig)
- ("libjpeg" ,libjpeg)))
(home-page "https://www.libgd.org/")
(synopsis "Library for the dynamic creation of images by programmers")
(description
@@ -113,8 +108,10 @@ most common applications of GD involve website development.")
("freetype" ,freetype)
("gd" ,gd)
("libpng" ,libpng)
- ("libjpeg" ,libjpeg)
+ ("libjpeg" ,libjpeg-turbo)
("zlib" ,zlib)))
+ (native-inputs
+ `(("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
(arguments
`(#:make-maker-flags
(list (string-append "--lib_jpeg_path="