summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bdff2ddada..2f4198fdea 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -432,6 +432,7 @@ Go. It also includes runtime support libraries for these languages.")
(base32
"11zd1hgzkli3b2v70qsm2hyqppngd4616qc96lmm9zl2kl9yl32k"))
(patches (search-patches "gcc-arm-bug-71399.patch"
+ "gcc-libsanitizer-ustat.patch"
"gcc-strmov-store-file-names.patch"
"gcc-5.0-libvtv-runpath.patch"
"gcc-5-source-date-epoch-1.patch"
@@ -452,7 +453,8 @@ Go. It also includes runtime support libraries for these languages.")
"$OBJDUMP_FOR_TARGET -T"))
#t))))
(inputs
- `(("isl" ,isl)
+ `(;; GCC5 needs <isl/band.h> which is removed in later versions.
+ ("isl" ,isl-0.18)
,@(package-inputs gcc-4.7)))))
(define-public gcc-6
@@ -832,7 +834,7 @@ as the 'native-search-paths' field."
(define-public isl
(package
(name "isl")
- (version "0.18")
+ (version "0.19")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -843,7 +845,7 @@ as the 'native-search-paths' field."
name "-" version ".tar.gz")))
(sha256
(base32
- "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))
+ "1n4yz9rj24mv226hqbpw210ifvqkn8dgvpnkzf0s0lkq9zrjd5ym"))))
(build-system gnu-build-system)
(inputs `(("gmp" ,gmp)))
(home-page "http://isl.gforge.inria.fr/")
@@ -861,6 +863,20 @@ reduction, transitive closures on maps (which may encode infinite graphs),
dependence analysis and bounds on piecewise step-polynomials.")
(license lgpl2.1+)))
+(define-public isl-0.18
+ (package
+ (inherit isl)
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "http://isl.gforge.inria.fr/isl-"
+ version ".tar.bz2")
+ (string-append %gcc-infrastructure
+ "isl-" version ".tar.gz")))
+ (sha256
+ (base32
+ "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))))
+
(define-public isl-0.11
(package
(inherit isl)