summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 04d0a85276..46b70ce497 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -451,7 +451,8 @@ Go. It also includes runtime support libraries for these languages.")
"$OBJDUMP_FOR_TARGET -T"))
#t))))
(inputs
- `(("isl" ,isl)
+ `(;; GCC5 needs <isl/band.h> which is removed in later versions.
+ ("isl" ,isl-0.18)
,@(package-inputs gcc-4.7)))))
(define-public gcc-6
@@ -831,7 +832,7 @@ as the 'native-search-paths' field."
(define-public isl
(package
(name "isl")
- (version "0.18")
+ (version "0.19")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -842,7 +843,7 @@ as the 'native-search-paths' field."
name "-" version ".tar.gz")))
(sha256
(base32
- "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))
+ "1n4yz9rj24mv226hqbpw210ifvqkn8dgvpnkzf0s0lkq9zrjd5ym"))))
(build-system gnu-build-system)
(inputs `(("gmp" ,gmp)))
(home-page "http://isl.gforge.inria.fr/")
@@ -860,6 +861,20 @@ reduction, transitive closures on maps (which may encode infinite graphs),
dependence analysis and bounds on piecewise step-polynomials.")
(license lgpl2.1+)))
+(define-public isl-0.18
+ (package
+ (inherit isl)
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (list (string-append "http://isl.gforge.inria.fr/isl-"
+ version ".tar.bz2")
+ (string-append %gcc-infrastructure
+ "isl-" version ".tar.gz")))
+ (sha256
+ (base32
+ "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))))
+
(define-public isl-0.11
(package
(inherit isl)